找规律,前后对称,同时猜想累加次数是几个数的乘积,于是考虑一个项(n-i),剩下一个应该到达中点的时候与(n-i)对换,猜为(i+1)
1104. Sum of Number Segments (20)
Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence {0.1, 0.2, 0.3, 0.4}, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) (0.4).
Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 105. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.
Output Specification:
For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.
Sample Input:4 0.1 0.2 0.3 0.4Sample Output:
5.00
#include <iostream>
#include <cstdio>
using namespace std;
int N;
int main()
{
double rst = 0, t;
cin >> N;
for(int i=0; i<N; i++) {
cin >> t;
rst += t * (N-i) * (i+1);
}
printf("%.2lf", rst);
return 0;
}