stars

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map. Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5
Sample Output
1
2
1
1
0
Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

这道题本质仍然是用树状数组处理逆序对数的问题,唯一不同的是,对于每一个数,将其插入序列之后我们可以得到与它形成逆序的数的个数,用该数所在的位置减去这个数即是它的level。
#include<cstdio>
#include<cstring>
#include<algorithm>
#define MAXN 15005
using namespace std;
struct node {
 int data;
 int pos;
}a[MAXN];
int c[MAXN],lev[MAXN];
int n;
bool cmp(node a,node b){
 if(a.data ==b.data ) return a.pos <b.pos ;
 return a.data <b.data ;
}
bool cmp1(node a,node b){
 return a.pos <b.pos ;
}
int lowbit(int x){
 return x&(-x);
}
void update(int x,int val){
     for(;x<=n;x+=lowbit(x))
  c[x]+=val;
}
int getsum(int x){
 int sum=0;
 for(;x;x-=lowbit(x)){
  sum+=c[x];
 }
 return sum;
}
int main(){
 scanf("%d",&n);
 memset(c,0,sizeof(c));
 memset(lev,0,sizeof(lev));
 int k;
 for(int i=1;i<=n;i++){
  scanf("%d %d",&a[i].data ,&k );
  a[i].pos =i;
 }
 sort(a+1,a+n+1,cmp);
 for(int i=1;i<=n;i++){
  a[i].data =i;
 }
 sort(a+1,a+n+1,cmp1);
 int t;
 for(int i=1;i<=n;i++){
  update(a[i].data ,1);
  t=i-getsum(a[i].data );
  lev[i-t]++;
 }
 for(int i=1;i<=n;i++){
  printf("%d\n",lev[i]);
 }
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值