pku 1050 To the Max

2009-10-07 

To the Max

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15
代码:

 

#include<stdio.h>
#include<string.h>
#define N 101
int a[N][N],b[N];
int maxsum(int b[101],int n)//求取一维的连续数字和
{
 int max,sum,i;
 max=0;//将最大值保存在max中
 sum=0;//保存连续的数字和
 for(i=0;i<n;i++)
 {
  if(sum<0) sum = b[i];//小于0 则可以舍掉
  else sum += b[i];
  if(sum>max)max=sum;
 }
 return max;
}
int main()
{
 int n,i,j,k,max,temp;
 scanf("%d",&n); 
 for(i=0;i<n;i++)
  for(j=0;j<n;j++)
   scanf("%d",&a[i][j]);
  max=a[0][0]; //保存整个二维矩阵中间的最大的子矩阵的和
  for(i=0;i<n;i++)
  {
   memset(b,0,sizeof(b)); //将连续的数行数字对应相加,保存在b[]中间
   for(k=i;k<n;k++) //求取连续的数行数字相加的和,依次叠加
   {
    for(j=0;j<n;j++)
    {     
     b[j]+=a[k][j];   
     
    }
    temp=maxsum(b,n); //求取连续k行相加后的最大子矩阵和
    if(temp>max)max=temp; 
   }     
  }
  printf("%d/n",max);
  return 0;
  
}
 
例如:
0 -2 -7 0 
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

我们可以把求矩阵的最大子矩阵和化成求一维的数组的,连续数字和最大,只是将连续的矩阵行进行了叠加。
先连续相加1-1  求出最大连续和;然后加上第二行的变成求 1-2 的对应列的和,求最大的连续和;再在原来的基础上加上第三行的数字变
成求1-3的最大连续和; 后面一次类推……
如题中结果是2-4行所得的b[]中1-2列的和最大,即为 
 9 2 
-4 1
-1 8
Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值