HDOJ 1231

最大连续子序列

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15649    Accepted Submission(s): 6862


Problem Description
给定K个整数的序列{ N1, N2, ..., NK },其任意连续子序列可表示为{ Ni, Ni+1, ..., 
Nj },其中 1 <= i <= j <= K。最大连续子序列是所有连续子序列中元素和最大的一个, 
例如给定序列{ -2, 11, -4, 13, -5, -2 },其最大连续子序列为{ 11, -4, 13 },最大和 
为20。 
在今年的数据结构考卷中,要求编写程序得到最大和,现在增加一个要求,即还需要输出该 
子序列的第一个和最后一个元素。
 

Input
测试输入包含若干测试用例,每个测试用例占2行,第1行给出正整数K( < 10000 ),第2行给出K个整数,中间用空格分隔。当K为0时,输入结束,该用例不被处理。
 

Output
对每个测试用例,在1行里输出最大和、最大连续子序列的第一个和最后一个元 
素,中间用空格分隔。如果最大连续子序列不唯一,则输出序号i和j最小的那个(如输入样例的第2、3组)。若所有K个元素都是负数,则定义其最大和为0,输出整个序列的首尾元素。 
 

Sample Input
  
  
6 -2 11 -4 13 -5 -2 10 -10 1 2 3 4 -5 -23 3 7 -21 6 5 -8 3 2 5 0 1 10 3 -1 -5 -2 3 -1 0 -2 0
 

Sample Output
  
  
20 11 13 10 1 4 10 3 5 10 10 10 0 -1 -2 0 0 0
Hint
Hint
Huge input, scanf is recommended.
 

Source
 

Recommend
JGShining
 
直接秒的一道题。
#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>
#include <cstring>
using namespace std;
const int MAXN = 10000 + 100;
#define inf 1 << 30
int a[MAXN];
int main()
{
    int n , k , sum;
    //freopen("in" , "r" , stdin);
    while(scanf("%d" , &n) , n)
    {

            int ok = 0;
            for(int i = 0 ; i < n ; i++)
            {
                scanf("%d" , &a[i]);
                if(a[i] >= 0)ok = 1;
            }
           if(ok)
           {
               int start  , end;
               start = end = a[0];
               k = sum = 0;
               int maxn = -inf;
               for(int i = 0 ; i < n ; i++)
               {
                   sum += a[i];
                   if(sum > maxn)
                   {
                       maxn = sum;
                       start = a[k];
                       end = a[i];
                   }
                   if(sum < 0)
                   {
                       sum = 0;
                       k = i + 1;
                   }
               }
               printf("%d %d %d\n", maxn , start , end);
           }
           else
           {
               printf("0 %d %d\n" , a[0] , a[n - 1]);
           }
    }
    return 0 ;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值