HDOJ 1009

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30514    Accepted Submission(s): 9833


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
  
  
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
  
  
13.333 31.500
 

一道经典的贪心入门题

LCY老师算法课的一道例题

题意是一只老鼠准备了N磅的猫粮用来贿赂守门的猫 ,在第i间房子里有j【i】磅的咖啡豆,看门猫要F【i】磅的猫粮。

如果老鼠付出F[i]* a% 磅猫粮他能得到 J[i]* a%磅的咖啡豆

求最大可获咖啡豆质量

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
int j[1005] , f[1005]  ;
double p [1005];
int main()
{
    int m , n , i , t ;
    double sum , max;
    while(cin >> m >> n)
    {
        if(m == -1&& n == -1)break;
        for ( i = 0 ; i < n ;i++)
        {
            cin >> j[i] >> f[i] ;
            p [i] = (double)j[i] / f[i] ;
        }

        sum = 0;
        while(m != 0 && n != 0)//从最大的p开始取
        {
                max = p[0];
            t = 0;
            for( i = 1 ; i < n ; i++)
            {
                if(max < p [i])
                {
                    max = p[i] ;
                    t =i ;
                }

            }
            if( m >= f[t])//每一步都尽可能取完
            {
                m -=f[t];
                sum +=j[t];
                p[t] = 0;
            }
            else
            {
                sum += (double)m * j [t] / f[t];
                m = 0;
            }
        }
        //cout << sum << endl;
        printf("%.3lf\n", sum);
    }
    return 0;
}
这题水题没啥意思 得意

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值