HDOJ 4577

X-Boxes

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 281    Accepted Submission(s): 98


Problem Description
Crazygirl is a crazy fan of XBOX games. Today, she’s here middle in a competition, in which the winner will be rewarded with an opportunity of working in the XBOX Company as a game testing player. Now, here comes the final game. As Cazygirl get a draw with the other competitor, Lich King, she must beat Lich this time.
The game is quite simple. There are n balls numbered from 1 to n and k boxes B 1, B 2,…, B k satisfying following conditions:
1.  With any ball x in box B i, there must be ball 2x in box B i+1 if there is a box B i+1;
2.  With any ball x in box B i, there must be ball y in box B i-1 satisfying 2y=x if there is a box B i-1;
3.  You can’t put a ball in two different boxes at the same time;
4.  Your score is the number of balls in box B 1;
5.  The player who get the highest score win the game of course.
So, you should tell Crazygirl the highest score she can get.

 

Input
The first line is the number of test cases.
Each test case has one line containing two integers n and k, meaning that there are n balls and k boxes. ( 1≤n≤10 10000, 2≤k≤25 )
 

Output
For each test case, output one line that contains an integer equals to the highest score you can get.
 

Sample Input
  
  
3 10 2 7 5 8 3
 

Sample Output
  
  
4 0 1
 

Source
 
参考了一位大神的写法,看来我的JAVA水平还是有待加强啊!
import java.io.*;
import java.util.*;
import java.math.*;
/**
 *
 * @author XM_zhou
 */
public class Main {
    public static void main(String[] args)
    {
        Scanner cin = new Scanner (new BufferedInputStream(System.in));
        int k , T;
        T = cin.nextInt();
        while(T>0)
        {
            T--;
                BigInteger n = cin.nextBigInteger();
                k = cin.nextInt();
                int tmp = (1 << k);
                BigInteger ans = BigInteger.ZERO;
                n = n.multiply(BigInteger.valueOf(2));
                while(n.compareTo(BigInteger.ZERO) > 0)
                {
                    n = n.divide(BigInteger.valueOf(tmp));
                    BigInteger tt = n.add(BigInteger.ONE).divide(BigInteger.valueOf(2));
                    ans = ans.add(tt);
                }
                System.out.println(ans);
                
        }
      
    }
}   


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值