POJ 3348 Cows 凸包

Cows

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 12101 Accepted: 5243

Description

Your friend to the south is interested in building fences and turning plowshares into swords. In order to help with his overseas adventure, they are forced to save money on buying fence posts by using trees as fence posts wherever possible. Given the locations of some trees, you are to help farmers try to create the largest pasture that is possible. Not all the trees will need to be used.

However, because you will oversee the construction of the pasture yourself, all the farmers want to know is how many cows they can put in the pasture. It is well known that a cow needs at least 50 square metres of pasture to survive.

Input

The first line of input contains a single integer, n (1 ≤ n ≤ 10000), containing the number of trees that grow on the available land. The next n lines contain the integer coordinates of each tree given as two integers x and y separated by one space (where -1000 ≤ x, y ≤ 1000). The integer coordinates correlate exactly to distance in metres (e.g., the distance between coordinate (10; 11) and (11; 11) is one metre).

Output

You are to output a single integer value, the number of cows that can survive on the largest field you can construct using the available trees.

Sample Input

4
0 0
0 101
75 0
75 101

Sample Output

151

Source

CCC 2007

 

参考资料:

https://blog.csdn.net/peng0614/article/details/81193484

凸包面积:

在凸包的边的点集上面,选定一个基点,然后其余的边分别与基点组成三角形,求一下面积。(此处三角形面积用平行四边形面积除以2,平行四边形面积就是基点向边的两点做的向量的叉乘的模长,用向量叉乘公式可以算出来,最后要除以2)。

 

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;
struct Point
{
    int x;
    int y;
    Point(int xx=0,int yy=0)
    {
        x = xx;
        y = yy;
    }
};
typedef struct Point Point;

Point p[10005];
int n;

int cmp(Point a,Point b)
{
    if(a.x == b.x)
    {
        return a.y<b.y;
    }
    return a.x<b.x;
}

vector<Point> u;
vector<Point> d;

int getCross(Point a,Point b)
{
    return a.x*b.y - a.y*b.x;
}
bool isclock(Point p0,Point p1,Point p2)
{
    Point a(p1.x-p0.x,p1.y-p0.y);
    Point b(p2.x-p0.x,p2.y-p0.y);
    if(getCross(a,b)<0)
    {
        return true;
    }
    else
    {
        return false;
    }
}

double getarea(Point p0,Point p1,Point p2)
{
    Point a(p1.x-p0.x,p1.y-p0.y);
    Point b(p2.x-p0.x,p2.y-p0.y);
    double tmp = getCross(a,b);
    if(tmp<0)
    {
        tmp = -tmp;
    }
    return tmp / 2.0;
}


int main()
{
    scanf("%d",&n);
    for(int i=0; i<n; i++)
    {
        scanf("%d%d",&p[i].x,&p[i].y);
    }
    sort(p,p+n,cmp);
    u.push_back(p[0]);
    u.push_back(p[1]);
    for(int i=2;i<n;i++)
    {
        for(int s = u.size();s>1 && isclock(u[s-2],u[s-1],p[i])==false;s--)
        {
            u.pop_back();
        }
        u.push_back(p[i]);
    }

    d.push_back(p[n-1]);
    d.push_back(p[n-2]);
    for(int i=n-3;i>=0;i--)
    {
        for(int s = d.size();s>1 && isclock(d[s-2],d[s-1],p[i])==false;s--)
        {
            d.pop_back();
        }
        d.push_back(p[i]);
    }

    for(int i=1;i<d.size()-1;i++)
    {
        u.push_back(d[i]);
    }
    double area = 0;
    for(int i=1;i<u.size()-1;i++)
    {
        area+= getarea(u[0],u[i],u[i+1]);
    }
    int ans = int(area / 50);
    printf("%d\n",ans);


    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值