Catch That Cow

Problem Description
 
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
 
Line 1: Two space-separated integers: N and K
 

Output
 
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
 
  
  
5 17
 

Sample Output
 
  4

 BFS+ 数学中的分情况讨论
 
 
<span style="color:#000000;">#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
int n,k;
int mark[100001];
struct node
{
	int x;
	int time;
}now,next;
queue<node>q;
void bfs()
{ 
   //while(!q.empty())
  // q.pop();//清空队列 
   now.x=n;
   now.time=0;
  mark[now.x]=1; 
   q.push(now);
   while(!q.empty())
   {
   	 now=q.front();//总是忘了写这个。一般队列用这个 
   	 q.pop();
   	 next=now;
   	for(int i=0;i<3;i++)
   	{
   		//now=q.front();//总是忘了写这个。一般队列用q.front(),优先队列用q.top(); 
   		if(i==0)
   		next.x=now.x+1;
   		if(i==1)
   		next.x=now.x-1;
   		if(i==2)
   		next.x=now.x*2;
   		next.time=now.time+1;//确定下一步走的方式之后,当前步数加1; 
   		if(next.x>10000||next.x<0)//由题意得到的范围 
   		continue;
   		if(next.x==k)
   		{
   		   printf("%d\n",next.time);
   	       return;//当时写的是continue,结果输出2个4;return;相当于本函数调用结束。 
   		}
   		if(mark[next.x]==0)
		   {
		   	 mark[next.x]=1;
		   	// next.time++;
		   	 q.push(next);
		   } 
   	}
   } 
   
}
int main()
{
	while(scanf("%d%d",&n,&k)!=EOF)
	{
		memset(mark,0,sizeof(mark));
		if(n==k)
		printf("0\n");//人牛一起 
		if(n>k)
		printf("%d\n",n-k);//人在牛前边
		if(n<k)//牛在人前边,这种是正常情况
		bfs();
		//printf("%d\n",next.time); 
	}
	return 0;
}</span>

 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值