Constructing Roads

Problem Description
 
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

Input
 
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

Output
 
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
 

Sample Input
 
  
  
3 0 990 692 990 0 179 692 179 0 1 1 2
 

Sample Output
 
  179
 
要解决的问题 1.怎么处理那些数据
          2.如何处理重边
          3.如何解决已连接的边,不用考虑重边,因为两点连过之后它俩的根结点就一样了,所以不会再连了。
 
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int per[110];
int n;
int dis[110][110];
struct node
{
	int s;
	int e;
    int len;	
}edge[5000];
int cmp(node a,node b)
{
	return a.len<b.len;
}

void init()
{
	for(int i=1;i<=n;i++)
	   per[i]=i;
}
int find(int x)
{
	int r=x;
	while(r!=per[r])
	    r=per[r];
	int i,j;
	    i=x;
	while(i!=r)
	{
	  j=per[i];
	  per[i]=r;
	  i=j;
	}
	return r;
}
int join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)//不用考虑重边的原因 
	{
		per[fx]=fy;
		return 1;
	}
	else
	  return 0;
}
int main()
{
	int Q,i,j,k;
	while(scanf("%d",&n)!=EOF)
	{    k=1;//初始化一定要在while之后 
		init();  
	  for(i=1;i<=n;i++)
	  {
	  	for(j=1;j<=n;j++)
	  	{
	  	  scanf("%d",&dis[i][j]);
	  	  if(j>i)//这是参考博客学到的,j>i得到的都是不重复的数据!!!此题难点 
	  	  {
	  	  	edge[k].s=i;//利用下标进行编号 
	  	  	edge[k].e=j;
	  	  	edge[k].len=dis[i][j];
	  	  	k++;
	  	  }
	  	 
	  	}
	  }	
	//  init(); 
	  sort(edge+1,edge+k,cmp);//因为刚开始是从1开始存的,所以排序也要从1开始排!!! 
	  scanf("%d",&Q);
	  int z,w;
	 for(i=0;i<Q;i++)
	 {
	 	scanf("%d%d",&z,&w);
	 	join(z,w);
	 }
	 int sum=0;
	for(i=1;i<k;i++)
	{
		if(join(edge[i].s,edge[i].e))
		   sum+=edge[i].len;
	}	
	printf("%d\n",sum);

    }
return 0;
}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值