Cube Stacking

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.

Input

* Line 1: A single integer, P

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.

Output

Print the output from each of the count operations in the same order as the input file.

Sample Input

 

<span style="font-size:14px;">6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4
</span>

Sample Output

<span style="font-size:14px;">1
0
2
</span>
<span style="font-size:14px;"></span> 
<span style="font-size:14px;color:#006600;">题解:题意:n个方块(n<=30000),p组操作(p<=100000),操作有两种,M a b 将含有a的堆放在包含b的堆上,还有一种是 C a统计a下面有多少个方块,
思路:带权并查集,一堆中最顶上的方块作为父节点,用dist[X] 统计X到父亲节点的距离,rank[fa[X]]表示团的大小,两者相减即为答案。</span>

 

 

 
<span style="font-size:14px;"></span><pre class="cpp" name="code">#include<stdio.h>
#include<string.h>
int n;
int per[32000];
int dis[32000];//<span style="color:#009900;">dis[x]表示x到父节点的距离 
</span>int rank[32000];//<span style="color:#009900;">rank[x]表示以x为根结点的团的大小 
</span>void init()
{
	for(int i=0;i<32000;i++)
	{
		per[i]=i;
		dis[i]=0; 
		rank[i]=1;
	}
}
int find(int x)
{
	if(x!=per[x])
	{
		int t=per[x];
		per[x]=find(per[x]);
		dis[x]+=dis[t];
	}
	return per[x];
}//<span style="color:#009900;">在找x根节点的同时,也计算出了x到根节点的距离。</span> 
int main()
{
	char ch; 
	while(scanf("%d",&n)!=EOF)
	{
		init();
		while(n--)
		{
			scanf("%c",&ch);
			getchar();
		    int x,y,a,b;
		    if(ch=='M')
		    {
		    	scanf("%d%d",&a,&b);
		    	int fx=find(a);
		    	int fy=find(b);
		    	if(fx!=fy)
		    	{
		    		per[fy]=fx;//<span style="color:#009900;">让a的根节点成为b的根节点,实现了含有a的堆放在含有b的堆上面。</span> 
		    		dis[fy]=rank[fx];//<span style="color:#009900;">计算b的根节点到新根节点的距离 
</span>		    		rank[fx]+=rank[fy];//<span style="color:#009900;">计算以fx为根节点的团的大小 
</span>		    	}
		    }
		  else
		  {
		  	scanf("%d",&a);
		  	int fa=find(a);
		  	printf("%d\n",rank[fa]-dis[a]-1);//<span style="color:#009900;">a的根节点所在的团的大小 减去 a到根节点的个数 减去 1。</span> 
		  }
		}
	}
	return 0;
}


                
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值