Problem Description
春天是鲜花的季节,水仙花就是其中最迷人的代表,数学上有个水仙花数,他是这样定义的:
“水仙花数”是指一个三位数,它的各位数字的立方和等于其本身,比如:153=1^3+5^3+3^3。
现在要求输出所有在m和n范围内的水仙花数。
Input
输入数据有多组,每组占一行,包括两个整数m和n(100<=m<=n<=999)。
Output
对于每个测试实例,要求输出所有在给定范围内的水仙花数,就是说,输出的水仙花数必须大于等于m,并且小于等于n,如果有多个,则要求从小到大排列在一行内输出,之间用一个空格隔开;
如果给定的范围内不存在水仙花数,则输出no;
每个测试实例的输出占一行。
Sample Input
100 120
300 380
Sample Output
no
370 371
#include<stdio.h>
#include<math.h>
#include<string.h>
int main()
{
int i,j,k;
int m,n;
int t,ans[1000];//起初这个数组是a[1000],结果出现invalid types 'int[int]' for array subscript(数组下标)
while(scanf("%d%d",&m,&n)==2)//出错原因是,数组名与整形变量重名!!!
{
memset(ans,0,sizeof(ans));
int a,b,c,d,e,f,h=0;
a=m/100;
<span style="color:#009900;">// b=m%100/10;本来想用这种方法剪枝的,没想到错就错到了这儿!
// c=m%10;
//d=n/100;
//e=n%100/10;
// f=n%10;
</span> for(i=a;i<=9;i++)
{
for(j=0;j<=9;j++)
{
for(k=0;k<=9;k++)
{
t=i*100+j*10+k;
if(i*i*i+j*j*j+k*k*k==t&&t>=m&&t<=n)
{
ans[h++]=t;
}
}
}
}
if(ans[0]==0)
printf("no\n");
else
{
for(i=0;i<h-1;i++)
printf("%d ",ans[i]);
printf("%d\n",ans[i]);
}
}
return 0;
}