A==B?

Problem Description
 
Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
 

Input
 
each test case contains two numbers A and B.
 
Output 
 
for each case, if A is equal to B, you should print "YES", or print "NO".
 

Sample Input
  
  
1 2 2 2 3 3 4 3
 

Sample Output
 
NO
YES
YES
NO
 
/*strstr(str1,str2) 函数用于判断字符串str2是否是str1的子串。如果是,则该函数返回str2在str1中首次出现的地址;否则,返回NULL。此题不需要考虑前导零,但要考虑小数点后面的零,因为若参与比较的数是小数时,把末尾的零去掉,方便比较*/
 
 
#include<stdio.h>
#include<string.h>
char a[50000],b[50000];
void clearzero(char*str)
{
	int i,len;
	len=strlen(str);
	if(strstr(str,".")!=NULL)//如果有小数点的话,才清零。点是一个字符串所以要用双引号括起来。 
	{
		for(i=len-1;str[i]=='0';i--)//注意遍历方向!! 
	     // len--;这是不对的。因为这样写根本没有达到去零的效果!!! 
	     str[i]='\0';
	   if(str[i]=='.')//如果小数点后面全是0,则小数点也抹掉! 
	      str[i]='\0';
	} 
	
}
int main()
{
	while(scanf("%s%s",a,b)!=EOF)
	{
		clearzero(a);
		clearzero(b);
		if(strcmp(a,b)==0)//两字符串比较时,遇‘\0’结束。 
		  printf("YES\n");
		else
		  printf("NO\n");
	}
	return 0;
} 


  • 4
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值