Number Sequence

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
 
2
5
 
 
参考别人的代码写的,希望有一天可以不参考别人的独立解决每道题。
 
#include<stdio.h>
//long f[1000000000];因为周期性的存在,所以不需要把数组开得这么大!
int f[210]; 
int main()
{
	int a,b;
	long n;
	while(scanf("%d%d%ld",&a,&b,&n),a||b||n)
	{
		if(n==1||n==2)
		{
			printf("1\n"); 
			continue;
		}
		int i,flag=1;
		f[1]=1;
		f[2]=1;
		for(i=3;i<=200;i++)//打表,找到一个周期就结束! 
		{
			f[i]=(a*f[i-1]+b*f[i-2])%7;
			if(f[i]==1&&f[i-1]==1)//出现周期 
			  break;
			if(f[i]==0&&f[i-1]==0)//这里有一个陷阱,当 a=7,b=7 时,后面都是零 
			{
				flag=0;
				break;
			}
		}
	  if(flag==0)
	  {
	  	printf("0\n");
	  	continue; 
	  } 
	   i=i-2;//i是周期 
	   if(n<i)
	     printf("%d\n",f[n]);
	   else
	   {
	   	  n=n%i;
	   	  if(n==0)
	   	    printf("%d\n",f[i]);
	   	  else
	   	    printf("%d\n",f[n]); 
	   } 
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值