PKU1692 Crossed Matchings

/*
Crossed Matchings
Time Limit: 1000MS        Memory Limit: 10000K
Total Submissions: 998        Accepted: 614

Description
There are two rows of positive integer numbers. We can draw one line segment between any two equal numbers, with values r, if one of them is located in the first row and the other one is located in the second row. We call this line segment an r-matching segment. The following figure shows a 3-matching and a 2-matching segment.

We want to find the maximum number of matching segments possible to draw for the given input, such that:
1. Each a-matching segment should cross exactly one b-matching segment, where a != b .
2. No two matching segments can be drawn from a number. For example, the following matchings are not allowed.

Write a program to compute the maximum number of matching segments for the input data. Note that this number is always even.

Input
The first line of the input is the number M, which is the number of test cases (1 <= M <= 10). Each test case has three lines. The first line contains N1 and N2, the number of integers on the first and the second row respectively. The next line contains N1 integers which are the numbers on the first row. The third line contains N2 integers which are the numbers on the second row. All numbers are positive integers less than 100.

Output
Output should have one separate line for each test case. The maximum number of matching segments for each test case should be written in one separate line.

Sample Input

3
6 6
1 3 1 3 1 3
3 1 3 1 3 1
4 4
1 1 3 3
1 1 3 3
12 11
1 2 3 3 2 4 1 5 1 3 5 10
3 1 2 3 2 4 12 1 5 5 3

Sample Output

6
0
8

Source
Tehran 1999*/

#include <iostream>
using namespace std;
int solution(int up[],int down[],int n1,int n2)
{
    int v[101][101] = {0};
    int i,j,m,n,mx;
    for(i = 1;i <= n1;i++)
    {
        for(j = 1;j <= n2;j++)
        {
            mx = 0;
            if(up[i] != down[j])
            {
                for(m = j - 1;m > 0;m--)
                {
                    if(up[i] == down[m])
                    {
                        for(n = i - 1;n > 0;n--)
                        {
                            if(up[n] == down[j])
                            {
                                if(n && m && mx < v[n - 1][m - 1] + 2)
                                {
                                    mx = v[n - 1][m - 1] + 2;
                                }
                               
                           
                            }
                        }
                    }
                }
            }
            if(mx < v[i - 1][j])
            {
                mx = v[i - 1][j];
            }
            if(mx < v[i][j - 1])
            {
                mx = v[i][j - 1];
            }
            if(mx < v[i - 1][j - 1])
            {
                mx = v[i - 1][j - 1];
            }
            v[i][j] = mx;

        }
    }
    return v[n1][n2];
}
int main(void)
{
    int N;
    cin>>N;
    int n1,n2;
    int up[101],down[101];
    while(N > 0)
    {
        N--;
        cin>>n1>>n2;
        for(int i = 1;i <= n1;i++)
        {
            cin>>up[i];
        }
        for(int j = 1;j <= n2;j++)
        {
            cin>>down[j];
        }
        cout<<solution(up,down,n1,n2)<<endl;
    }

    return 0;
}

 

 

动态规划好题。。。首先创建一个数组V[101][101]用于存储状态,V[I][J]表示当第一行I个第二行J个数字时最多的连线的条数(最开始留空V[0][0] = 0,最开始从V[1][1]开始,这样初状态的描述简单点)

本题的难点在于2个。。1个就是动态规划最重要的状态转换。。。设当前情况是V[I][J]时。。这个时候分4种情况。。即是点i和点j都有线连出来,i和j都没有线连出来,i有线连出来而j没有,i没有线连出来而j有。。

这4种情况中比较后最大的那个就是V[I][J]时最多可以有的线的条数。。

第2个难点就是对于以上4种情况。。。。我们必须看出每种情况其实都包含有一种共同的情况。。那就是点i和点j都有线连出来这种情况。。。。于是我们的方程是针对这种情况的。。从这2个点开始往前找线(mx = v[n - 1][m - 1] + 2)。。。得出最佳的MAX后再与其他三种情况比较后得出最大值。

 

深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值