PKU1251 Jungle Roads 最小生成树样例题(艾这就叫差距阿。。。。。。。。。。

/*
Jungle Roads
Time Limit: 1000MS        Memory Limit: 10000K
Total Submissions: 5039        Accepted: 2257

Description

The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

Input
The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

Output
The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30

Source
Mid-Central USA 2002
*/














#include <iostream>
#include <string.h>
using namespace std;

int min1 = 101;
int sum = 0;

int sign[26][26] = {0};
int lastq,lastw;


void prim(int road[][26],int n)
{
    for(int q = 0;q < n -1;q++)
    {
       
        for(int qq = 0;qq < 26;qq++)
        {
            for(int ww = 0;ww < 26;ww++)
            {
                if(!(sign[qq][0] == 1 && sign[ww][0] == 1) && !(sign[qq][0] == 0 && sign[ww][0] == 0) && (sign[qq][ww] == 0) && min1 > road[qq][ww])
                {
                    min1 = road[qq][ww];                   
                    lastq = qq;
                    lastw = ww;
                }
            }
        }
        sum = sum + min1;
        min1 = 101;
        sign[lastq][lastw] = 1;
        sign[lastq][0] = 1;
        sign[lastw][0] = 1;
        road[lastw][lastq] = road[lastq][lastw];
       
    }
       
       
       
       
   
    cout<<sum<<endl;
    sum = 0;
    min1 = 101;
    for(int uu = 0;uu < 26;uu++)
    {
        for(int yy = 0;yy < 26;yy++)
        {
            sign[uu][yy] = 0;
            road[uu][yy] = 101;
        }
    }


    return;
}
int main(void)
{
    int road[26][26];
    for(int y = 0;y < 26;y++)
    {
        for(int u = 0;u < 26;u++)
        {
            road[y][u] = 101;
        }
    }
   
    int n;
    char ch;
    int num;
    int k,g;
    while(cin>>n)
    {
        if(n == 0)
        {
            break;
        }
        else
        {
            for(int i = 0;i < n - 1;i++)
            {
                cin>>ch;
                k = ch - 'A';
               
                cin>>num;
                for(int j = 0;j < num;j++)
                {
                    cin>>ch;
                    g = ch - 'A';
                    cin>>road[k][g];
                    road[g][k] = road[k][g];
                   
                }
            }
            sign[0][0] = 1;
            prim(road,n);
        }
    }

    return 0;
}
第一题最小生成树的题目。。。花了太长时间这题。。。没想到遇上一个新的算法类型就卡成这样。。。用的PRIM算法。。。。花了10多个钟头的时间一个通宵阿到现在是第2天晚上了都没睡呢= =|||。。。。不过收获很大。。。从复杂到简单吧。。最开始的时候想用K算法搞了N久搞不成而且K比起PRIM来首先一点就是路径要排序了。。接着开始用PRIM。。整个算法就是找一条路径如果他的一点是已搜到的一点是未搜到的且他在当前已生成的树的各点的选择中是最短的就用他。。。简简单单一句话实现起来真的一波三折阿。。。。。。。。这就叫差距吧。。。给别人作或许不到几分钟就OK了而对我来说却是如此大的数量级的差距阿。。。不过至少可以肯定一点自己虽然笨但真的很喜欢。。。看到提交上去accepted字样那个高兴阿。。。代码也短还是0MS呢=V=。。。继续努力阿阿阿阿

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值