2016计算机学科夏令营上机考试: F:Dungeon Master 六个方向的BFS

总时间限制: 1000ms 内存限制: 65536kB 题目
描述
You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?
输入
The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a ‘#’ and empty cells are represented by a ‘.’. Your starting position is indicated by ‘S’ and the exit by the letter ‘E’. There’s a single blank line after each level. Input is terminated by three zeroes for L, R and C.
输出
Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!
样例输入

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

样例输出

Escaped in 11 minute(s).
Trapped!

思路:
题意:
相当于一栋大楼里面很多秘密通道,S是起始位置,E是终点位置,‘#’是墙,‘.’是路,问从S出发最少经过多长时间就到达E处;

分析:
和迷宫不同的是,迷宫是平面上东南西北的移动,相当于在大楼里面的一层楼里找出口,而这个题目在迷宫的基础上又增加了上下的移动,即大楼里面的上下层之间的移动,
所以需要建立三维的数组,找到S的位置,移动方向由4个增加到6个,直到找到E为止,如果找遍了所有的能走的地方都没找到出口E,就出不来了!!!

代码

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
#include<string>
using namespace std;
char a[35][35][35];
int  b[35][35][35];
int L,R,C;
int f[3][6]={{1,-1,0, 0,0, 0},
          {0, 0,1,-1,0, 0},
          {0, 0,0, 0,1,-1}};
int s2[35][35][35];
int flag;
struct Knot
{
    int x,y,z;
    int step;
};
Knot c,d;
bool search1(int x,int y,int z)
{
    return (x>=1&&x<=L&&y>=1&&y<=R&&z>=1&&z<=C);
}
int bfs(int si,int sj,int sk)
{
    queue<Knot>s;
    c.x=si;
    c.y=sj;
    c.z=sk;
    c.step=0;
    s.push(c);
    while (!s.empty())
    {
        d=s.front();
        s.pop();
        c.step=d.step+1;
        for (int i=0;i<6;i++)
         {
             c.x=d.x+f[0][i];
             c.y=d.y+f[1][i];
             c.z=d.z+f[2][i];
             if (search1(c.x,c.y,c.z)&&!b[c.x][c.y][c.z]&&a[c.x][c.y][c.z]!='#')
             {
                 if (a[c.x][c.y][c.z]=='E')
                 return c.step;
                    b[c.x][c.y][c.z]=1;
                    s.push(c);
             }
         }
    }
    return -1;
}
int main()
{
    int i,j,k;
    int si,sj,sk;
    while (cin>>L>>R>>C&&(L!=0||R!=0||C!=0))
    {
        memset(b,0,sizeof(b));
        for (i=1;i<=L;i++)
            for (j=1;j<=R;j++)
              for (k=1;k<=C;k++)
          {
            cin>>a[i][j][k];
            if (a[i][j][k]=='S')
                {
                    si=i;
                    sj=j;
                    sk=k;
                }
          }
          flag=bfs(si,sj,sk);
          if (flag==-1)
            cout << "Trapped!" << endl;
          else
             cout << "Escaped in " << flag << " minute(s)." << endl;

    }
    return 0;
}

代码2(未ac)

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<string>
#include<vector>
#include<queue>
#include<set>
#include<stack>
using namespace std;
const int MAX = 30;
//三维BFS搜索
//解决迷宫问题: DFS中将起点信息(下标)作为输入,BFS中起点信息保存在全局结构体变量S E中
//解决岛屿"块"问题,BFS需要枚举每个位置,所以直接将起点信息(x,y)作为输入
struct node
{
    int x,y,z;
    int step;
}S,E,Node;
char G[MAX][MAX][MAX];
bool visit[MAX][MAX][MAX]={false};
int L,R,C;
//方向数组
int X[]={1,-1,0,0,0,0};
int Y[]={0,0,1,-1,0,0};
int Z[]={0,0,0,0,1,-1};
int check(int x,int y,int z)
{
    //超过边界
    if(x>=L||x<0||y>=R||y<0||z>=C||z<0) return 0;
    //正常情况
    if(visit[x][y][z]==1||G[x][y][z]=='#')
    {
        return 0;
    }
    else
    {
        visit[x][y][z]=1;
        return 1;
    }

}
void success(int k)
{
    cout<<"Escaped in "<<k<<" minute(s)."<<endl;
}
void fail()
{
    cout<<"Trapped!"<<endl;
}
int BFS()
{
    queue<node> q;
    q.push(S);
    while(!q.empty())
    {
        //检查队首元素 出口返回
        node temp = q.front();
        q.pop();
        if(temp.x==E.x&&temp.y==E.y&&temp.z==E.z) return temp.step;
        //检查下一层次结点
        for(int i=0;i<6;i++)
         {
             if(check(temp.x+X[i],temp.y+Y[i],temp.z+Z[i]))
             {
                 Node.x=temp.x+X[i];
                 Node.y=temp.y+Y[i];
                 Node.z=temp.z+Z[i];
                 Node.step=temp.step+1;
                 q.push(Node);
             }
         }
    }
    return -1; //队列为空仍没有返回值,说明不存在解
}

int main()
{
    freopen("input.txt","r",stdin);
    int L,R,C;
    while(cin>>L>>R>>C&&L!=0&&R!=0&&C!=0)
    {
        char temp;
        for(int i=0;i<L;i++)
            for(int j=0;j<R;j++)
                for(int k=0;k<C;k++)
                {
                    cin>>temp;
                    while(temp=='\n') cin>>temp;//过滤换行符输入的是char
                    if(temp=='S')
                    {
                        S.x=i;S.y=j;S.z=k;S.step=0;
                        visit[i][j][k]=1;
                    }
                    else if(temp=='E')
                    {
                        E.x=i;E.y=j;E.z=k;E.step=0;
                    }
                    G[i][j][k]=temp;
                }
         for(int i=0;i<L;i++)
            {
                cout<<endl;
                for(int j=0;j<R;j++)
                for(int k=0;k<C;k++)
                    cout<<G[i][j][k];
            }
        int steps=BFS();
        if(steps!=-1) success(steps);
        else fail();
    }
    return 0;
}
Dungeon Master》通常是一个角色扮演游戏的概念,特别是在桌面游戏如龙与地下城(Dungeons & Dragons)中,DM(Dungeon Master)代表了游戏主持人或 Dungeon Master,负责创造、引导和管理游戏世界。在C++中,要实现这样一个游戏的一个简化版本,涉及到图形用户界面设计、游戏逻辑和规则处理等复杂部分。下面是一个非常基础的命令行版的角色扮演战斗模拟示例,不是完整的Dungeon Master游戏,但它展示了如何创建简单的角色和回合制战斗: ```cpp #include <iostream> #include <string> class Character { public: int health; int attack; Character(int h, int a): health(h), attack(a) {} void attack(Character& enemy) { if (health > 0 && enemy.health > 0) { int damage = attack - enemy.defense; std::cout << "You dealt " << damage << " damage to the enemy.\n"; enemy.health -= damage; if (enemy.health <= 0) std::cout << "Enemy defeated!\n"; } } private: int defense; // 假设每个角色有自己的防御值 }; int main() { Character player(100, 20); // 创建玩家,假设健康为100,攻击为20 Character enemy(50, 10); // 创建敌人,假设健康为50,攻击为10 while (player.health > 0 && enemy.health > 0) { player.attack(enemy); if (player.health <= 0) break; enemy.attack(player); // 敌人反击 } return 0; } ``` 这只是一个非常简化的例子,真正的《Dungeon Master》游戏将包括更复杂的地图探索、事件管理、角色技能系统、道具系统等。如果你想在C++中构建这样的完整游戏,你可能会需要学习并利用一些游戏开发库,例如SFML、Unity C#脚本或是Unreal Engine。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值