1016. Phone Bills (25)-PAT

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word "on-line" or "off-line".

For each test case, all dates will be within a single month. Each "on-line" record is paired with the chronologically next record for the same customer provided it is an "off-line" record. Any "on-line" records that are not paired with an "off-line" record are ignored, as are "off-line" records not paired with an "on-line" record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
Sample Output:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80
推荐指数:※
这道题注意逻辑:
1.It is guaranteed that at least one call is well paired in the input. 这句话只是保证的一个输入一定有输出,但没有保证每个人都会有输出。
2.on-off配对
3.把总价钱算出来,在除以100
4.理清逻辑,快速排序
#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<vector>
#include<map>
using namespace std;
const int HOURS=24;
const int NAME=21;
typedef struct Record{
	char name[NAME];
	int mou;
	int dd;
	int hh;
	int mm;
	char line[10];
}Record;
typedef struct Res{
	float money;
	int last_time;
}Res;
int compare_name(const void *a ,const void *b){
	int tmp=strcmp(((Record*)a)->name,((Record *)b)->name);
	if(tmp==0){
		if(((Record*)a)->mou!=((Record *)b)->mou)
			return ((Record*)a)->mou-((Record *)b)->mou;
		if(((Record*)a)->dd!=((Record *)b)->dd)
			return ((Record*)a)->dd-((Record *)b)->dd;
		if(((Record*)a)->hh!=((Record *)b)->hh)
			return ((Record*)a)->hh-((Record *)b)->hh;
		if(((Record*)a)->mm!=((Record *)b)->mm)
			return ((Record*)a)->mm-((Record *)b)->mm;
	}
	else
		return tmp;
}
void compute_money(Record *r1,Record *r2,int *rate, Res *res){
	Record r;
	r.dd=r1->dd;
	r.hh=r1->hh;
	r.mm=r1->mm;
	res->money=0;
	res->last_time=0;
	while(r.dd<r2->dd||r.hh<r2->hh||r.mm<r2->mm){
		res->money+=rate[r.hh];
		res->last_time++;
		r.mm++;
		if(r.mm>=60){
			r.mm=0;
			r.hh++;
			if(r.hh>=24){
				r.hh=0;
				r.dd++;
			}
		}
	}
	res->money/=100;
}
int check_ok(Record *r,int index,int n){
	char pname[NAME];
	int i,flag=0,has=0;
	strcpy(pname,r[index].name);
	for(i=index;i<n;i++){
		if(strcmp(r[i].name,pname)==0){
			if(r[i].line[1]=='n'){
				flag=1;
			}
			else if(r[i].line[1]=='f'&&1==flag){
				flag=0;
				has=1;
			}
		}
		else
			break;
	}
	return has;
}
int main()
{
	int rate[HOURS];
	int i,n;
	for(i=0;i<HOURS;i++)
		scanf("%d",&rate[i]);
	scanf("%d",&n);
	Record *r=new Record [n];
	for(i=0;i<n;i++){
		scanf("%s",r[i].name);
		scanf("%d:%d:%d:%d",&r[i].mou,&r[i].dd,&r[i].hh,&r[i].mm);
		scanf("%s",r[i].line);
	}
	qsort(r,n,sizeof(Record),compare_name);
	if(n>0){
		i=0;
		while(i<n){
			int has=check_ok(r,i,n);
			char pname[NAME];
			if(1==has){
				printf("%s %02d\n",r[i].name,r[i].mou);
				strcpy(pname,r[i].name);
				int flag=0;
				float t_money=0;
				Record rn;
				while(strcmp(pname,r[i].name)==0){
					if(r[i].line[1]=='n'){
						rn.dd=r[i].dd;
						rn.hh=r[i].hh;
						rn.mm=r[i].mm;
						flag=1;
					}
					else if(r[i].line[1]=='f'&&1==flag){
						flag=0;
						printf("%02d:%02d:%02d %02d:%02d:%02d",rn.dd,rn.hh,rn.mm,r[i].dd,r[i].hh,r[i].mm);
						Res res;
						compute_money(&rn,&r[i],rate,&res);
						printf(" %d $%.2f\n",res.last_time,res.money);
						t_money+=res.money;

					}
					i++;
				}
				printf("Total amount: $%.2f\n",t_money);
			}
			else
				i++;
		}
	}
	return 0;
}
提供两组测试数据
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
12
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
bab 01:05:02:24 off-line
bab 01:04:23:59 off-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
2
bab 01:05:02:24 off-line
bab 01:04:23:59 off-line



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值