1010-Tempter of the Bone -HDUOJ

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 52780    Accepted Submission(s): 14191


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
  
  
NO
YES
 
Author
ZHANG, Zheng
 

推荐指数:※※※

来源:http://acm.hdu.edu.cn/showproblem.php?pid=1010

这道题也是DFS+剪枝

1.最短路径剪枝,如果时间少于最短路径,一定到达不了
2.奇偶剪枝,如果时间大于最短路径,就是要做迂回,必须要多偶数时间才能到达终点。
3.数据不一定是按严格矩阵排列的。用scanf的同学注意。

#include<iostream>
#include<string.h>
#include<string>
#include<vector>
#include<math.h>
using namespace std;
int n,m,t;
vector< vector<char> > maze;
vector< vector<int> > visit;
int si,sj,di,dj;
int neigh[4][2]={{-1,0},{1,0},{0,-1},{0,1}};
bool is_ok(int i,int j){
	return (i>=0&&i<n&&j>=0&&j<m);
}
bool dfs(int usetime,int i,int j){
	if(is_ok(i,j)==false)
		return false;
	if(usetime==t){
		if(maze[i][j]=='D')
			return true;
		else
			return false;
	}
	if(maze[i][j]=='X')
		return false;
	int tmp_road;
	tmp_road=t-usetime-abs(di-i)-abs(dj-j);
	if(tmp_road<0||(tmp_road>0&&tmp_road&1))
		return false;
	int t;
	for(t=0;t<4;t++){
		if(is_ok(i+neigh[t][0],j+neigh[t][1])&&visit[i+neigh[t][0]][j+neigh[t][1]]==0){
			visit[i+neigh[t][0]][j+neigh[t][1]]=1;
			if(dfs(usetime+1,i+neigh[t][0],j+neigh[t][1])==false)
				visit[i+neigh[t][0]][j+neigh[t][1]]=0;
			else
				return true;

		}
	}
	return false;
}
int main()
{
	while(cin>>n>>m>>t&&n){
		int i,j;
		maze.clear();
		visit.clear();
		for(i=0;i<n;i++){
			vector <char> tmp;
			vector <int> tmp_visit;
			char block;
			for(j=0;j<m;j++){
				cin>>block;
				if(block=='S'){
					si=i;
					sj=j;
				}else if(block=='D'){
					di=i;
					dj=j;
				}
				tmp.push_back(block);
				tmp_visit.push_back(0);
			}
			maze.push_back(tmp);
			visit.push_back(tmp_visit);
		}
		visit[si][sj]=1;
		if(dfs(0,si,sj)==true)
			cout<<"YES"<<endl;
		else
			cout<<"NO"<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值