1055. The World's Richest (25)-PAT

1055. The World's Richest (25)

时间限制
200 ms
内存限制
128000 kB
代码长度限制
16000 B
判题程序
Standard

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=105) - the total number of people, and K (<=103) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [-106, 106]) of a person. Finally there are K lines of queries, each contains three positive integers: M (<= 100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line "Case #X:" where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person's information occupies a line, in the format

Name Age Net_Worth
The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output "None".

Sample Input:
12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50
Sample Output:
Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None
推荐指数:※
来源:http://pat.zju.edu.cn/contests/pat-a-practise/1055
这道题目本身的逻辑很清楚,就是具体处理的时候考虑其给出的”each contains three positive integers: M (<= 100) - the maximum number of outputs“,感谢:Linest Blog http://linest.github.io/blog/2013/05/23/1/ 关于这个的提醒(本来case 2一直过不了)。这样其实每个年龄的人,多不会超过100,因为多的也不会输出。PAT的有些题目的测试集也不能掉以轻心。
#include <iostream>
#include<string.h>
#include<stdlib.h>
#include<stdio.h>
using namespace std;
#define  N 100001
int n,k;
typedef struct people{
	char strname[10];
    int age;
	int money;
	bool visited;
}people; 
people *peop;
int query[3];
int compare_money(const void *a ,const void *b)
{
	if(((people *)a)->money>((people *)b)->money
	  ||((people *)a)->age<((people *)b)->age&&((people *)a)->money==((people *)b)->money
	  ||((people *)a)->age==((people *)b)->age&&((people *)a)->money==((people *)b)->money
	                                &&strcmp(((people *)a)->strname,((people *)b)->strname)<0)
		return -1;
	else
		return 1;
}
int main()
{
	int i,j;
	scanf("%d%d",&n,&k);
	peop=new people[n];
	for(i=0;i<n;i++){
		scanf("%s%d%d",peop[i].strname,&peop[i].age,&peop[i].money);
	}
	qsort(peop,n,sizeof(people),compare_money);
	int filter_num=0, filter[N],age_count[201]={0};
	for(i=0;i<n;i++){
		if(++age_count[peop[i].age]<101)//thank Linest,this line stolen from his blog
			filter[filter_num++]=i;
	}
	for(i=0;i<k;i++){
		scanf("%d%d%d",&query[0],&query[1],&query[2]);
		printf("Case #%d:\n",i+1);
		int flag=0;
		int print_num=0;
		for(j=0;j<filter_num&&print_num<query[0];j++){
			int tmp=filter[j];
			int age=peop[tmp].age;
			if(age>=query[1]&&age<=query[2]){
				printf("%s %d %d\n",peop[tmp].strname,peop[tmp].age,peop[tmp].money);
				print_num++;
			}
		}
		if(print_num==0)
			printf("None\n");
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值