Contest1376 - "师创杯"烟台大学第二届ACM程序设计精英赛复现 A--A Repeating Characters

Description

For this problem,you will write a program that takes a string of characters,S,and creates a new string of characters,T,with each character repeated R times.That is,R copies of the first character of S,followed by R copies of the second character of S,and so on.Valid characters for S are the QR
Code “alphanumeric” characters:
     0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ$%*+-. /:

Input

The first line of input contains a single integer P,(1<=P<=1000),which is the number of data sets that follow. Each data set is single line of input consisting of the data set number N,followed by a space,followed by the repeat count R,(1<=R<=8),followed by a space ,followed by the string S.The length of string S will always be at least one and  no more than 20 characters.All the characters will be from the set of characters shown above.

Output

For each data set there is one line of output. It contains the data set number,
N, followed by a single apace which is then followed by the new string T,which is made of each character in S repeated R times.

Sample Input

2
1 3 ABC
2 5 /HTP

Sample Output

1 AAABBBCCC
2 /HHHHHTTTTTPPPPP

HINT

AC代码:

#include <iostream>
#include <cstring>
using namespace std;
void fun(string s,char output[],int num){
    int i,count=0,j,m;
    for(i=0;i<(m=s.length());i++){
        j=0;
        while(j<num){
            output[count++]=s[i];
            j++;
        }
    }
    i=0;
    while(i<count)
                cout<<output[i++];
    cout<<'\12';
}
int main(){
    int n,i,num,a;
    string s;
    char output[1000];
    cin>>n;
    i=0;
    while(i<n){
        cin>>a;
        cin>>num;
        cin>>s;
        cout<<a<<" ";
        fun(s,output,num);
        i++;
    }
    return 0;
}


运行结果:

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值