Contest1376 - "师创杯"烟台大学第二届ACM程序设计精英赛复现 B--Faultfinding

Description

Do you remember the game in which we find difference among several similar pictures? Now we change it into digital version. There are N digits, same or different. Please find how many different digits there are among them and output the number.

Input

Each group of the first line is N (1<=N<=10000). The second line consists N integers.

Output

The number of different digits.

Sample Input

2
1 1
3 
1 2 3

Sample Output

1
3

HINT

代码:

#include <iostream>
using namespace std;
void sort(int my[],int n){
    int temp;
    for(int i=0;i<n;i++)
    for(int j=0;j<n-i-1;j++){
        if(my[j]>my[j+1]){
            temp=my[j];
            my[j]=my[j+1];
            my[j+1]=temp;
        }
    }
}
void fun(int my[],int n){
    int count=n;
    for(int i=0;i<n;i++){
        if(my[i]==my[i+1])
            count--;
    }
    cout<<count<<'\12';
}
int main(){
    int n,i;
    while(cin>>n){
        int my[n];
        i=0;
        while(i<n){
            cin>>my[i++];
        }
        sort(my,n);
        fun(my,n);
        i++;
    }

    return 0;
}


运行结果:

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值