POJ 1988 Cube Stacking 并查集

Cube Stacking
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 21388 Accepted: 7488
Case Time Limit: 1000MS

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.

Input

* Line 1: A single integer, P

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.

Output

Print the output from each of the count operations in the same order as the input file.

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

Source


ACcode:

#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#define maxn 100000+5
using namespace std;
int set[maxn],cnt[maxn],top[maxn];
///set[k]为元素k所在栈的栈底元素
///cnt[k]为[k……set[k]]的元素个数
///top[k]为元素k所在栈的栈顶元素序号
int set_find(int p){
    if(set[p]<0)
        return p;
    if(set[set[p]]>=0){
        int fa=set[p];
        set[p]=set_find(fa);
        cnt[p]+=cnt[fa];
    }
    return set[p];
}
void set_join(int x,int y){
    x=set_find(x);
    y=set_find(y);
    set[x]=y;
    set_find(top[y]);
    cnt[x]=cnt[top[y]]+1;
    top[y]=top[x];
}
int main(){
    int p;
    scanf("%d",&p);
    memset(set,-1,sizeof(set));
    memset(cnt,0,sizeof(cnt));
    for(int i=0;i<maxn;++i)
        top[i]=i;
    while(p--){
        char s[5];
        scanf("%s",s);
        if(s[0]=='M'){
            int x,y;
            scanf("%d%d",&x,&y);
            set_join(x,y);
        }else{
            int x;
            scanf("%d",&x);
            set_find(x);
            printf("%d\n",cnt[x]);
        }
    }
    return 0;
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值