UVA 10158 War 并查集

D - War(8.4.3)
Crawling in process... Crawling failed Time Limit:3000MS    Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Download as PDF

Problem B: War

 

 

    A war is being lead between two countries, A and B. As a loyal citizen of C, you decide to help your country’s espionage by attending the peace-talks taking place these days (incognito, of course). There are n people at the talks (not including you), but you do not know which person belongs to which country. You can see people talking to each other, and through observing their behaviour during their occasional one-to-one conversations, you can guess if they are friends or enemies. In fact what your country would need to know is whether certain pairs of people are from the same country, or they are enemies. You may receive such questions from C’s government even during the peace-talks, and you have to give replies on the basis of your observations so far. Fortunately nobody talks to you, as nobody pays attention to your humble appearance.

 

  Abstract

    Now, more formally, consider a black box with the following operations:

               setFriends(x, y)     shows that x and y are from the same country

               setEnemies(x, y)   shows that x and y are from different countries

               areFriends(x, y)     returns true if you are sure that x and y are friends

               areEnemies(x, y)   returns true if you are sure that x and y are enemies

    The first two operations should signal an error if they contradict with your former knowledge. The two relations ‘friends’ (denoted by ~) and ‘enemies’ (denoted by *) have the following properties:

              ~ is an equivalence relation, i.e.

1.      If x ~ y and y ~ z then x ~ z  (The friends of my friends are my friends as well.)

2.      If x ~ y then y ~ x                  (Friendship is mutual.)

3.      x ~ x                                       (Everyone is a friend of himself.)

              * is symmetric and irreflexive

4.      If x * y then y * x                  (Hatred is mutual.)

5.      Not x * x                                (Nobody is an enemy of himself.)

              Also

6.      If x * y and y * z then x ~ z   (A common enemy makes two people friends.)

7.      If x ~ y and y * z then x * z   (An enemy of a friend is an enemy.)

    Operations setFriends(x, y) and setEnemies(x, y) must preserve these properties.

 

 

  Input

     The first line contains a single integer, n, the number of people.

     Each of the following lines contains a triple of integers, c x y, where c is the code of the operation:

            c = 1, setFriends

            c = 2, setEnemies

            c = 3, areFriends

            c = 4, areEnemies

     and x and y are its parameters, which are integers in the range [0, n), identifying two (different) people. The last line contains 0 0 0.

    All integers in the input file are separated by at least one space or line break.

 

  Output

     For every ‘areFriends’ and ‘areEnemies’ operation write 0 (meaning no) or 1 (meaning yes) to the output. Also for every ‘setFriends’ or ‘setEnemies’ operation which contradicts with previous knowledge, output a –1 to the output ; note that such an operation should produce no other effect and execution should continue. A successful ‘setFriends’ or ‘setEnemies’ gives no output.

    All integers in the output file must be separated by at least one space or line break.

 

  Constraints

    n < 10000, the number of operations is unconstrained.

 

 

  Sample Input

            10

            1 0 1

            1 1 2

            2 0 5

            3 0 2

            3 8 9

            4 1 5

            4 1 2

            4 8 9

            1 8 9

            1 5 2

            3 5 2

            0 0 0

 

  Sample Output

            1

            0

            1

            0

            0

            -1

            0

 ACcode:

#include <cstdio>
#include <iostream>
#define maxn 20000+5
using namespace std;
int set[maxn],n,loop;
int set_find(int t){
    if(set[t]<0)
        return t;
    else return set_find(set[t]);
}
int areFriends(int x,int y){
    if(set_find(x)!=set_find(y)&&set_find(x)!=set_find(y+n))return -1;
    if(set_find(x)==set_find(y))return 1;
    return 0;
}
int areEnemies(int x,int y){
    if(set_find(x)==set_find(y+n))return 1;
    else return -1;
}
int setFriends(int x,int y){
    if(areFriends(x,y)==0){
            return -1;
    }
    if(areFriends(x,y)==-1){
        set[set_find(x)]=set_find(y);
        set[set_find(x+n)]=set_find(y+n);
    }
    return 1;
}
int setEnemies(int x,int y){
    if(areFriends(x,y)==1)return -1;
    if(areFriends(x,y)==-1){
        set[set_find(x+n)]=set_find(y);
        set[set_find(x)]=set_find(y+n);
    }
    return 1;
}
int main(){
    scanf("%d",&n);
    for(int i=0;i<2*n+10;++i)set[i]=-1;
    int c,x,y,t;
    while(scanf("%d%d%d",&c,&x,&y)!=EOF&&(c||x||y)){
        if(c==1){
            t=setFriends(x,y);
            if(t==-1)printf("-1\n");
        }
        else if(c==2){
            t=setEnemies(x,y);
            if(t==-1)printf("-1\n");
        }
        else if(c==3){
            t=areFriends(x,y);
            printf(t==1?"1\n":"0\n");
        }else if(c==4){
            t=areEnemies(x,y);
            printf(t==1?"1\n":"0\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值