POJ 3126 Pime Path bfs

Prime Path
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14440 Accepted: 8148

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. 

Now, the minister of finance, who had been eavesdropping, intervened. 
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top

ACcode:

#include <map>
#include <queue>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#define rd(x) scanf("%d",&x)
#define rd2(x,y) scanf("%d%d",&x,&y)
#define ll long long int
#define maxn 100005
#define mod 1000000007
#define INF 0x3f3f3f3f //int×î´óÖµ
#define FOR(i,f_start,f_end) for(int i=f_start;i<=f_end;++i)
#define MT(x,i) memset(x,i,sizeof(x))
#define PI  acos(-1.0)
#define E  exp(1)
using namespace std;
struct node{
    int k,step;
}h[100000];
bool p[11000];
int x,y,loop,s[11000];
void get_prime(){
    MT(p,0);
    p[0]=1;
    p[1]=1;
    FOR(i,2,9999)
        if(!p[i])
            for(int j=i*i;j<=9999;j+=i)
                p[j]=1;
}
int change(int x,int i,int j){
    if(i==1)return (x/10)*10+j;else
    if(i==2)return (x/100)*100+x%10+j*10;else
    if(i==3)return (x/1000)*1000+x%100+j*100;else
    if(i==4)return (x%1000)+j*1000;
}
int main(){
    get_prime();
    rd(loop);
    while(loop--){
        rd2(x,y);
        h[1].k=x;
        h[1].step=0;
        MT(s,100);
        int ans=-1;
        int pos=1,r=1;
        while(1){
            if(h[pos].k==y){
                ans=h[pos].step;
                break;
            }
            int tk,ts;
            FOR(i,1,4)
                FOR(j,0,9)
                    if(!((j==0)&&(i==4))){
                        tk=change(h[pos].k,i,j);
                        if(p[tk])continue;
                        ts=h[pos].step+1;
                        if(ts>=s[tk])continue;
                        if(tk==y){
                            ans=ts;
                            break;
                        }
                        s[tk]=ts;
                        r++;
                        h[r].k=tk;
                        h[r].step=ts;
                    }
            if(pos==r||ans>=0)break;
                pos++;
        }
        if(ans>=0)
            printf("%d\n",ans);
        else
            printf("Impossible\n");
    }
    return 0;
}
/**
3
1033 8179
1373 8017
1033 1033
**/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值