HDU 2844 Coins 多重背包

Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10236    Accepted Submission(s): 4083


Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 

Output
For each test case output the answer on a single line.
 

Sample Input
  
  
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 

Sample Output
  
  
8 4
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   2159  2955  1203  1171  1864 
套模板
ACcode:
#pragma warning(disable:4786)//使命名长度不受限制
#pragma comment(linker, "/STACK:102400000,102400000")//手工开栈
#include <map>
#include <set>
#include <queue>
#include <cmath>
#include <stack>
#include <cctype>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#define rd(x) scanf("%d",&x)
#define rd2(x,y) scanf("%d%d",&x,&y)
#define rds(x) scanf("%s",x)
#define rdc(x) scanf("%c",&x)
#define ll long long int
#define maxn 100000+10
#define mod 1000000007
#define INF 0x3f3f3f3f //int 最大值
#define FOR(i,f_start,f_end) for(int i=f_start;i<=f_end;++i)
#define MT(x,i) memset(x,i,sizeof(x))
#define PI  acos(-1.0)
#define E  exp(1)
using namespace std;
int Max(int a,int b){return a>b?a:b;}
int c[maxn],w[maxn],num[maxn],f[maxn];///c:费用 w:价值 num:
int V,n,m;
void ZeroOnePack(int c,int w){
    for(int v=V;v>=c;v--)
        f[v]=Max(f[v],f[v-c]+w);
}
void CompletePack(int c,int w){
    for(int v=c;v<=V;v++)
        f[v]=Max(f[v],f[v-c]+w);
}
void MultiplePack(int c,int w,int nl){
    if(c*nl>=V)
        CompletePack(c,w);
    else {
        int k=1;
        while(k<nl){
            ZeroOnePack(k*c,k*w);
            nl-=k;k<<=1;
        }
        ZeroOnePack(nl*c,nl*w);
    }
}
int main(){
    while(rd2(n,m),(n+m)){
        V=m;MT(f,0);
        FOR(i,1,n)rd(c[i]);
        FOR(i,1,n)rd(num[i]);
        FOR(i,1,n)
        MultiplePack(c[i],c[i],num[i]);
        int cc=0;
        FOR(i,1,m)if(i==f[i])cc++;
        printf("%d\n",cc);
    }
    return 0;
}
/*
3 10
1 2 4 2 1 1
2 5
1 4 2 1
*/

 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值