大二训练第二周 Count the Colors 线段区间更新

C - Count the Colors
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.

Your task is counting the segments of different colors you can see at last.


Input



The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.

Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.


Output



Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.

If some color can't be seen, you shouldn't print it.

Print a blank line after every dataset.


Sample Input



5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1


Sample Output



1 1
2 1
3 1

1 1

0 2
1 1

区间更新模板题
树区间一直都是1~8k

ACcode:
#pragma warning(disable:4786)//使命名长度不受限制
#pragma comment(linker, "/STACK:102400000,102400000")//手工开栈
#include <map>
#include <set>
#include <queue>
#include <cmath>
#include <stack>
#include <cctype>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#define rd(x) scanf("%d",&x)
#define rd2(x,y) scanf("%d%d",&x,&y)
#define rds(x) scanf("%s",x)
#define rdc(x) scanf("%c",&x)
#define ll long long int
#define maxn 8005
#define mod 1000000007
#define INF 0x3f3f3f3f //int 最大值
#define FOR(i,f_start,f_end) for(int i=f_start;i<=f_end;++i)
#define MT(x,i) memset(x,i,sizeof(x))
#define PI  acos(-1.0)
#define E  exp(1)
using namespace std;
int tree[maxn<<2],c[maxn<<2],cnt[maxn<<2],ans[maxn<<2];
inline void pushdown(int st){
    int temp=st<<1;
    c[temp]=c[temp+1]=c[st];
    c[st]=-1;
}
void updata(int st,int left,int right,int L,int R,int id){
    if(L<=left&&R>=right){
        c[st]=id;
        return ;
    }
    if(c[st]==id)return;
    if(c[st]!=-1)pushdown(st);
    int m=(left+right)>>1;
    int temp=st<<1;
    if(L<=m)
        updata(temp,left,m,L,R,id);
    if(R>m)
        updata(temp+1,m+1,right,L,R,id);
}
void qurey(int st,int left,int right){
    if(c[st]>=0){
        FOR(i,left,right)
            cnt[i]=c[st];
        return;
    }
    if(left!=right&&c[st]==-1){
        int m=(right+left)>>1;
        int temp=st<<1;
        qurey(temp,left,m);
        qurey(temp+1,m+1,right);
    }
}
int main(){
    int n;
    while(rd(n)!=EOF){
        MT(c,-1);
        int a,b,c;
        FOR(i,1,n){
            rd2(a,b);rd(c);
            if(a>=b)continue;
            updata(1,1,8000,a+1,b,c);
        }
        MT(cnt,-1);
        qurey(1,1,8000);
        MT(ans,0);
        int i=1;
        while(i<maxn){
            int cc=cnt[i],j=i+1;
            if(cc==-1){++i;continue;}
            while(cnt[j]!=-1&&cnt[j]==cc&&j<maxn)++j;
            ++ans[cc];
            i=j;
        }
        FOR(i,0,maxn)
            if(ans[i])
                printf("%d %d\n",i,ans[i]);
        printf("\n");
    }
    return 0;
}
/*
5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值