山东省第一届ACM大学生程序设计竞赛 hello world! 水模拟

Hello World!

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

We know that Ivan gives Saya three problems to solve (Problem F), and this is the first problem.
We need a programmer to help us for some projects. If you show us that you or one of your friends is able to program, you can pass the first hurdle.
I will give you a problem to solve. Since this is the first hurdle, it is very simple.”
We all know that the simplest program is the “Hello World!” program. This is a problem just as simple as the “Hello World!”
In a large matrix, there are some elements has been marked. For every marked element, return a marked element whose row and column are larger than the showed element’s row and column respectively. If there are multiple solutions, return the element whose row is the smallest; and if there are still multiple solutions, return the element whose column is the smallest. If there is no solution, return -1 -1.
Saya is not a programmer, so she comes to you for help
Can you solve this problem for her?

输入

The input consists of several test cases.
The first line of input in each test case contains one integerN (0<N1000), which represents the number of marked element.
Each of the nextN lines containing two integers r and c, represent the element’s row and column. You can assume that 0<r, c300. A marked element can be repeatedly showed.
The last case is followed by a line containing one zero.

输出

For each case, print the case number (1, 2 …), and for each element’s row and column, output the result. Your output format should imitate the sample output. Print a blank line after each test case.

示例输入

3
1 2
2 3
2 3

0

示例输出

Case 1:
2 3
-1 -1
-1 -1

提示

 

来源

 2010年山东省第一届ACM大学生程序设计竞赛

水模拟,给你一些二维平面的点。

求对于每个点,第一个x,y坐标都大于它的点没有输出-1 -1


ACcode:

#include <set>
#include <queue>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#define maxn 1005
using namespace std;
pair<int ,int >my[maxn];
int main(){
    int n,loop=1;
    char str[10];
    while(~scanf("%d",&n)&&n){
        set<pair<int ,int> >mm;
        printf("Case %d:\n",loop++);
        for(int i=1;i<=n;++i){
            scanf("%d%d",&my[i].first,&my[i].second);
            mm.insert(my[i]);
        }
        for(int i=1;i<=n;++i){
            set<pair <int,int> >::iterator id=mm.lower_bound(my[i]);
            while(id!=mm.end()){
                if(id->first>my[i].first&&id->second>my[i].second){
                    printf("%d %d\n",id->first,id->second);
                    break;
                }
                id++;
            }
            if(id==mm.end())printf("-1 -1\n");
        }
        printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值