HDU 4487 Maximum Random Walk 概率 dp

D - Maximum Random Walk
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

Consider the classic random walk: at each step, you have a 1/2 chance of taking a step to the left and a 1/2 chance of taking a step to the right. Your expected position after a period of time is zero; that is, the average over many such random walks is that you end up where you started. A more interesting question is what is the expected rightmost position you will attain during the walk. 
 

Input

The first line of input contains a single integer P, (1 <= P <= 15), which is the number of data sets that follow. Each data set should be processed identically and independently. 

Each data set consists of a single line of input consisting of four space-separated values. The first value is an integer K, which is the data set number. Next is an integer n, which is the number of steps to take (1 <= n <= 100). The final two are double precision floating-point values L and R 
which are the probabilities of taking a step left or right respectively at each step (0 <= L <= 1, 0 <= R <= 1, 0 <= L+R <= 1). Note: the probably of not taking a step would be 1-L-R. 
 

Output

For each data set there is a single line of output. It contains the data set number, followed by a single space which is then followed by the expected (average) rightmost position you will obtain during the walk, as a double precision floating point value to four decimal places. 
 

Sample Input

     
     
3 1 1 0.5 0.5 2 4 0.5 0.5 3 10 0.5 0.4
 

Sample Output

     
     
1 0.5000 2 1.1875 3 1.4965

 




一个人在原点随机走n步 每次向左走的概率为L,向右走的概率为R 不走的概率是 1-R-L

问走的过程中向右走最远的期望

设dp【i,j,k】表示第i步走到j了此时曾经到过最远距离为k的概率

ACcode:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
double dp[2][202][202];
int main(){
    int loop;
    scanf("%d",&loop);
    while(loop--){
        int cnt,step,k;
        double l,r,s,ans;
        scanf("%d%d%lf%lf",&cnt,&step,&l,&r);
        s=1.0-l-r;
        memset(dp,0,sizeof(dp));
        dp[0][100][100]=1;
        for(int i=1;i<=step;++i)
            for(int j=100-i;j<=100+i;j++){
                for(k=j>100?j:100;k<=100+i;++k){
                    if(j==k)
                        dp[i&1][j][k]=dp[(i+1)&1][j][k]*s+dp[(i+1)&1][j-1][k-1]*r+dp[(i+1)&1][j-1][k]*r;
                    else
                        dp[i&1][j][k]=dp[(i+1)&1][j][k]*s+dp[(i+1)&1][j-1][k]*r+dp[(i+1)&1][j+1][k]*l;
                }
            }
        ans=0;
        for(int j=101;j<=101+step;++j)for(int i=100-step;i<=100+step;++i)ans+=dp[step&1][i][j]*(j-100);
        printf("%d %.4f\n",cnt,ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值