1002. A+B for Polynomials (25)
时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
This time, you are supposed to find A+B where A and B are two polynomials.
Input
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.
Output
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2
分析:这题我中坑了,想了一会,题目输入的指数都是非负的,但系数可以是负的啊。所以相加如果是0就不要塞进去了。这题用数组模拟也可以,原谅我现在能用stl的都不想自己造数据结构了......
Ps:不懂map的点这里~~~
#include<stdio.h>
#include<iostream>
#include<map>
#include<algorithm>
using namespace std;
int main()
{
//freopen(".txt","r",stdin);
map<int,double,greater<int> >m1;//放第一行,指数作为key,按照大到小排序
map<int,double,greater<int> >m2;//放第二行
map<int,double,greater<int> >m3;//放结果
int k;
cin>>k;
for(int i=0;i<k;i++){
int ex;
double co;
cin>>ex>>co;
m1[ex]=co;
}
cin>>k;
for(int i=0;i<k;i++){
int ex;
double co;
cin>>ex>>co;
m2[ex]=co;
}
map<int,double,greater<int> >::iterator it2;
map<int,double,greater<int> >::iterator it1;
for(it1=m1.begin(),it2=m2.begin();it1!=m1.end()&&it2!=m2.end();){
while(it2!=m2.end()&&it1!=m1.end()&&it1->first>it2->first){//it1的指数大就先放到m3里
m3[it1->first]=it1->second;
it1++;
}
while(it1!=m1.end()&&it2!=m2.end()&&it2->first>it1->first){//it2的指数大就先放到m3里
m3[it2->first]=it2->second;
it2++;
}
while(it2!=m2.end()&&it1!=m1.end()&&it2->first==it1->first){/*相等就加起来放进去,但是啊,系数和为0就不要放进去了,这样保证后面map的size是正确的。*/
if(it2->second+it1->second!=0)
m3[it2->first]=it2->second+it1->second;
it2++;
it1++;
}
}
while(it1!=m1.end()){//剩余的直接全放进去,补漏
m3[it1->first]=it1->second;
it1++;
}
while(it2!=m2.end()){//剩余的直接全放进去,补漏
m3[it2->first]=it2->second;
it2++;
}
cout<<m3.size();
it1=m3.begin();
while(it1!=m3.end()){
printf("% d %.1lf",it1->first,it1->second);
it1++;
}
return 0;
}
//it2的指数大就先放到m3里
m3[it2->first]=it2->second;
it2++;
}
while(it2!=m2.end()&&it1!=m1.end()&&it2->first==it1->first){/*相等就加起来放进去,但是啊,系数和为0就不要放进去了,这样保证后面map的size是正确的。*/
if(it2->second+it1->second!=0)
m3[it2->first]=it2->second+it1->second;
it2++;
it1++;
}
}
while(it1!=m1.end()){//剩余的直接全放进去,补漏
m3[it1->first]=it1->second;
it1++;
}
while(it2!=m2.end()){//剩余的直接全放进去,补漏
m3[it2->first]=it2->second;
it2++;
}
cout<<m3.size();
it1=m3.begin();
while(it1!=m3.end()){
printf("% d %.1lf",it1->first,it1->second);
it1++;
}
return 0;
}