九度OJ题目1124:Digital Roots

题目1124:Digital Roots

时间限制:1 秒

内存限制:32 兆

特殊判题:

题目描述:

    The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

    For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

输入:

    The input file will contain a list of positive integers, one per line.
    The end of the input will be indicated by an integer value of zero.

输出:

    For each integer in the input, output its digital root on a separate line of the output.

样例输入:
24
39
0
样例输出:
6
3
提示:

The integer may consist of a large number of digits.

来源:
2008年北京大学方正实验室计算机研究生机试真题 
 
#include <stdio.h>
#include <string.h>
 
void digital_roots (char data[]){
    int ans;
    int len;
    int i;
 
    len = strlen (data);//len表示输入整数的位数
    ans = 0;
    for (i=0; i<len; ++i)
        ans += data[i] - '0';//各数位的数值相加
    i = 0;
    while (ans){ //数位拆解
        data[i] = ans % 10 + '0';
        ans /= 10;
        ++i;
    }
    data[i] = '\0';//字符串结束符
}
 
int main(void){
    char input[10001];
 
    while (scanf ("%s", input) != EOF && input[0] != '0'){ //输入整数,输入0表示输入结束
        while (strlen (input) > 1){
            digital_roots (input);
        }
        printf ("%d\n", input[0] - '0');//输出结果
    }
 
    return 0;
}
/************************************************************** 
    Problem: 1124 
    User: zpy
    Language: C++ 
    Result: Accepted 
    Time:10 ms 
    Memory:1020 kb 
****************************************************************/  

                            
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值