九度OJ题目1440:Goldbach's Conjecture

题目1440:Goldbach's Conjecture

时间限制:1 秒

内存限制:128 兆

特殊判题:

题目描述:

Goldbach's Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.
This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.

输入:

An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.

输出:

Each output line should contain an integer number. No other characters should appear in the output.

样例输入:
6
10
12
0
样例输出:
1
2
1
#include <stdio.h>
#include <math.h>
 
int IsPrime(int n){ //判断一个数是否为素数
    if(n<=1) return 0;
    int sq=(int)sqrt(n)+1;//计算枚举上界
    while(sq>=2){
        if(n%sq==0)
            break;
        --sq;
    }
    return(sq>=2)?0:1;
}
int main(){
    int n;
    while(scanf("%d",&n)!=EOF&&n!=0){ //输入n
        int k=0;//保存结果
        for(int i=2;i<=n/2;i++){ //枚举上界为n/2
            if(IsPrime(i)==1&&IsPrime(n-i)==1)//如果i和n-i都是素数,k加1
                k++;
        }
        printf("%d\n",k);//输出结果并换行
    }
    return 0;
}
/**************************************************************
    Problem: 1440
    User: zpy
    Language: C++
    Result: Accepted
    Time:50 ms
    Memory:1032 kb
****************************************************************/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值