hdoj1003-Max Sum(数组的最大和)

Problem Description
Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output
Case 1:
14 1 4

Case 2:
7 1

       题目的大致意思就是求有最大和的子序列,我的方法是边读取数据边处理,当和出现为负值是记录当前点的前一个为右端点,当和大于最大值是更新左右端点;
特别要注意的是数据可能全为负,因此max的值应初始化为-1005。

#include <iostream>
#include <fstream>
using namespace std;
int main()
{
    //ifstream cin("data.in");
    int t;
    cin >> t;
    int count = 1;
    while(t --)
    {
        int n;
        cin >> n;
        int l = 0, l1 = 0, r = 0,  sum = 0, r1 = 0, max = -1005;               //数组有可能全为负,max初始值为-1005

        for(int i = 0; i < n; i ++)
        {
            int temp;
            cin >> temp;
            sum += temp;
            if(sum > max)
            {      //出现最大值时更新右端点
                l = l1;
                r1 = i;
                max = sum;
            }
            else if(sum < 0)
            {     //当当前和为负数时,更新左端点
                sum = 0;
                l1 = i + 1;
            }
        }
        if(count > 1)
        {
            cout << endl;
        }
        cout << "Case " << count++ << ":" << endl;
        cout << max << " " << l+1 << " " << r1+1 << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值