Red and Black

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.  

Write a program to count the number of black tiles which he can reach by repeating the moves described above.  

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.  

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.  

'.' - a black tile  
'#' - a red tile  
'@' - a man on a black tile(appears exactly once in a data set)  
The end of the input is indicated by a line consisting of two zeros.  

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

题目大意:输入一个矩阵只有一个'@',其他都是‘.’或'#','#'代表红色砖块‘.’代表黑色砖块,‘@’,是人站的初始位置,只能走黑色砖块,输出一共能走多少个黑色砖块,含脚下的一个。

题目链接:http://poj.org/problem?id=1979

源代码:

#include<cstdio>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
char a[20][20];
int d[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
int sum,l,h;
bool yj(int x,int y)
{
    if(x<0||y<0||x>=h|y>=l)
        return 0;
    return 1;
}
void search1(int x,int y)
{
    int xx,yy;
    int i;
    sum++;
    a[x][y]='#';
    for(i=0;i<4;i++)
    {
        xx=x+d[i][0];
        yy=y+d[i][1];
        if(yj(xx,yy)&&(a[xx][yy]=='.'))
            search1(xx,yy);
    }
}
int main()
{
    int i,j,x0,y0;
    while(~scanf("%d%d",&l,&h))
    {
        getchar();
        if(l==0&&h==0)
            break;
        sum=0;
        for(i=0;i<h;i++)
        {
            for(j=0;j<l;j++)
            {
                scanf("%c",&a[i][j]);
                if(a[i][j]=='@')
                {
                    x0=i;
                    y0=j;
                }
            }
            getchar();
        }
        search1(x0,y0);
        printf("%d\n",sum);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值