6-19 方阵的转置
分数 10
全屏浏览
切换布局
作者 杨军
单位 四川师范大学
编写一个类用于处理3×3矩阵转置,测试转置的效果,输出转置前后的矩阵。
函数接口定义:
根据要求写出类,并可以使得主函数正确运行,得到对应的结果。
裁判测试程序样例:
/* 请在这里填写答案 */ 在这里给出函数被调用进行测试的例子。例如: int main(){ Matrix m; m.input(); m.show(); m.transform(); m.show(); }
输入样例:
在这里给出一组输入。例如:
1 2 3
4 5 6
7 8 9
输出样例:
注意每个元素前面有一个空格字符。例如:
datas:
1 2 3
4 5 6
7 8 9
datas:
1 4 7
2 5 8
3 6 9
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB
#include<bits/stdc++.h>
using namespace std;
class Matrix{
int a[3][3];
public:
void input(){
for(int i=0;i<3;i++){
for(int j=0;j<3;j++){
cin>>a[i][j];
}
}
}
void show(){
cout<<"datas:"<<endl;
for(int i=0;i<3;i++){
for(int j=0;j<3;j++){
cout<<' '<<a[i][j];
}
cout<<endl;
}
}
void transform(){
int t;
for(int i=0;i<3;i++){
for(int j=i;j<3;j++){
t=a[i][j];
a[i][j]=a[j][i];
a[j][i]=t;
}
}
}
};