hdu2639Bone Collector II(第K大背包)

Bone Collector II

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3780    Accepted Submission(s): 1947


Problem Description
The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link: http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the K-th maximum of the total value (this number will be less than 2 31).
 

Sample Input
  
  
3 5 10 2 1 2 3 4 5 5 4 3 2 1 5 10 12 1 2 3 4 5 5 4 3 2 1 5 10 16 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
12 2 0
 

Author
teddy
 

Source
题意就要在V的背包装的第K大物品
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int a[10000],b[10000],c[10000],d[10000];
int dp[1000][1000];
int main()
{
    int m,i,j,v1,v2,k;
    scanf("%d",&m);
    while(m--)
    {
        int n;
        scanf("%d%d%d",&n,&v1,&v2);
        for(i=0;i<n;i++)
        scanf("%d",&a[i]);
        for(i=0;i<n;i++)
        scanf("%d",&b[i]);
       memset(dp,0,sizeof(dp));
       for(i=0;i<n;i++)
       {
           for(j=v1;j>=b[i];j--)//01背包
           {
               for( k=1;k<=v2;k++)//把0~K大的背包都求出来。
               {
                    c[k]=dp[j-b[i]][k]+a[i];//c[K]指的是背包第K大是该物品取。
                    d[k]=dp[j][k];//d[k]指的是背包第K大该物品给不取
               }
               c[k]=d[k]=-1;//做结束用的
               int x,y,z;
               x=y=z=1;//x是控制dp的,y是控制c的,z控制d的。
               while(x<=v2&&(c[y]!=-1||d[z]!=-1))//开始将c和d排序给dp
               {
                   if(c[y]>d[z])
                   {
                       dp[j][x]=c[y];
                       y++;
                   }
                   else
                   {
                       dp[j][x]=d[z];
                       z++;
                   }
                   if(dp[j][x]!=dp[j][x-1])//因为两个第K大没有相等的
                    x++;
               }
           }
       }
        printf("%d\n",dp[v1][v2]);
    }


    return 0;
}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值