杭电oj1002

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
 
 
2 1 2 112233445566778899 998877665544332211
 

Sample Output
 
 
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

int main(){
	int n,sum[1024];
	string a,b;
	cin>>n;
	for(int t=1;t<=n;t++)  //t为执行次数
	{
		int i,j,m=0,k=0,temp=0,p=0;
		cin>>a>>b;
		i=a.length();
		j=b.length();  //i,j,分别为a,b两个字符串的长度
		i=i-1;
		j=j-1;
		while(i>=0&&j>=0)  //数组从0开始,最大为i-1和j-1 
		{
			m=a[i]-'0';
			k=b[j]-'0';
			sum[p++]=(temp+m+k)%10;	//用数组存储相加的值,从个位开始存储	
			temp=(temp+m+k)/10; 	//temp表示进位 
			i--;
			j--;
			
		} //从后向前加,一直加到第一个数
		
		if(i>j)		//如果a比较长 	
		{
			while(i>=0)
			{
		
				m=a[i]-'0';
				sum[p++]=(temp+m)%10;
				temp=(temp+m)/10;
			
				i--;
		 	}
		 } 
		 
		 
		 if(i<j)		//如果b比较长 
		 {
		 	while(k>=0)
		 	{
			 
		 		k=b[j]-'0';
		 		sum[p++]=(temp+k)%10;
		 		temp=(temp+k)/10;
		 	
		 		j--;
			}	
		 }
		sum[p]=temp;				//最高位是否有进位 
		 cout<<"Case "<<t<<":"<<endl;
		 cout<<a<<"+"<<b<<" = ";
		if(sum[p]!=0)				//如果最高位有进位,输出最高位 
			cout<<sum[p];
		 for(--p;p>=0;p--)		//逆序输出数组中的元素 
		 	cout<<sum[p];
		 cout<<endl;
		 
		 if(t<n) 
		 	cout<<endl; 
		
	 }
	  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值