Kejin Player

Problem Description
Cuber QQ always envies those Kejin players, who pay a lot of RMB to get a higher level in the game. So he worked so hard that you are now the game designer of this game. He decided to annoy these Kejin players a little bit, and give them the lesson that RMB does not always work.
This game follows a traditional Kejin rule of “when you are level i, you have to pay ai RMB to get to level i+1”. Cuber QQ now changed it a little bit: “when you are level i, you pay ai RMB, are you get to level i+1 with probability pi; otherwise you will turn into level xi (xi≤i)”.
Cuber QQ still needs to know how much money expected the Kejin players needs to ``ke’’ so that they can upgrade from level l to level r, because you worry if this is too high, these players might just quit and never return again.

Input
The first line of the input is an integer t, denoting the number of test cases.
For each test case, there is two space-separated integers n (1≤n≤500 000) and q (1≤q≤500 000) in the first line, meaning the total number of levels and the number of queries.
Then follows n lines, each containing integers ri, si, xi, ai (1≤ri≤si≤109, 1≤xi≤i, 0≤ai≤109), space separated. Note that pi is given in the form of a fraction risi.
The next a lines are q queries. Each of these queries are two space-separated integers l and r (1≤l<r≤n+1).
The sum of n and sum of q from all t test cases both does not exceed 106.

Output
For each query, output answer in the fraction form modulo 109+7, that is, if the answer is PQ, you should output P⋅Q−1 modulo 109+7, where Q−1 denotes the multiplicative inverse of Q modulo 109+7.

Sample Input
1
3 2
1 1 1 2
1 2 1 3
1 3 3 4
1 4
3 4

Sample Output
22
12

#include<bits/stdc++.h>
typedef long long ll;
using namespace std;
const int maxn=500010;
ll ans[maxn],n,r,s,x,a,q,res,l,mod=1e9+7;
ll ksm(ll a,ll n){
    ll res=1;
    while(n){
        if(n&1) res=(res*a)%mod;
        a=(a*a)%mod;
        n>>=1;
    }
    return res%mod;
}
ll inv(ll a){
    return ksm(a,mod-2);
}
int main(){
    int T; scanf("%d",&T);
    while(T--){
        ans[1]=0;
        scanf("%lld%lld",&n,&q);
        for(int i=1;i<=n;i++){
            scanf("%lld%lld%lld%lld",&r,&s,&x,&a);
            ll pp=(((((s-r)*inv(s))%mod)*((ans[i]-ans[x]+mod)%mod))%mod+a)%mod;
            ans[i+1]=((((s*pp)%mod)*inv(r))%mod+ans[i])%mod;
        }
        while(q--){
            scanf("%lld%lld",&l,&r);
            printf("%lld\n",(ans[r]-ans[l]+mod)%mod);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值