**
A strange lift
**
Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button “UP” , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button “DOWN” , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can’t go up high than N,and can’t go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button “UP”, and you’ll go up to the 4 th floor,and if you press the button “DOWN”, the lift can’t do it, because it can’t go down to the -2 th floor,as you know ,the -2 th floor isn’t exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button “UP” or “DOWN”?
Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,….kn.
A single 0 indicate the end of the input.
Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can’t reach floor B,printf “-1”.
Sample Input
5 1 5
3 3 1 2 5
0
Sample Output
3
思路:
可以转化为最短路问题。
要知道从A到B至少需要按多少次按钮,从A可以经过其他楼层,再到B,也就类似于中从一点到另一点的最短路可以经过中间点来获得最短路的问题。
用dijkstra来实现
代码:
#include<cstdio>
#include<cstring>
#define inf 100000
const int N=205;
int nu[N];
int dp[N][N];
int dis[N];int n;
bool vis[N];int a,b;
void dijkstra(int s)
{
for(int i=1;i<=n;i++) dis[i]=dp[s][i];
memset(vis,0,sizeof(vis));
vis[s]=1;
for(int i=1;i<n;i++)
{
int min=inf,p=s;
for(int i=1;i<=n;i++)
if(!vis[i]&&dis[i]<min)
min=dis[i],p=i;
vis[p]=1;
for(int i=1;i<=n;i++)
{
if(!vis[i]&&dis[i]>dis[p]+dp[p][i])
dis[i]=dis[p]+dp[p][i];
}
}
}
int main()
{
while(scanf("%d",&n)!=EOF)
{
if(n==0) break;
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
if(i!=j) dp[i][j]=inf;
else dp[i][j]=0;
scanf("%d%d",&a,&b);
for(int i=1;i<=n;i++)
{
scanf("%d",&nu[i]);
if(i+nu[i]<=n)dp[i][i+nu[i]]=1;
if(i-nu[i]>=1)dp[i][i-nu[i]]=1;
}
dijkstra(a);
printf("%d\n",dis[b]==inf?-1:dis[b]);
}
return 0;
}