Marriage Match II HDU - 3081(最大流+并查集+二分)

Presumably, you all have known the question of stable marriage match. A girl will choose a boy; it is similar as the game of playing house we used to play when we are kids. What a happy time as so many friends playing together. And it is normal that a fight or a quarrel breaks out, but we will still play together after that, because we are kids.
Now, there are 2n kids, n boys numbered from 1 to n, and n girls numbered from 1 to n. you know, ladies first. So, every girl can choose a boy first, with whom she has not quarreled, to make up a family. Besides, the girl X can also choose boy Z to be her boyfriend when her friend, girl Y has not quarreled with him. Furthermore, the friendship is mutual, which means a and c are friends provided that a and b are friends and b and c are friend.
Once every girl finds their boyfriends they will start a new round of this game—marriage match. At the end of each round, every girl will start to find a new boyfriend, who she has not chosen before. So the game goes on and on.
Now, here is the question for you, how many rounds can these 2n kids totally play this game?
Input
There are several test cases. First is a integer T, means the number of test cases.
Each test case starts with three integer n, m and f in a line (3<=n<=100,0<m<nn,0<=f<n). n means there are 2n children, n girls(number from 1 to n) and n boys(number from 1 to n).
Then m lines follow. Each line contains two numbers a and b, means girl a and boy b had never quarreled with each other.
Then f lines follow. Each line contains two numbers c and d, means girl c and girl d are good friends.
Output
For each case, output a number in one line. The maximal number of Marriage Match the children can play.
Sample Input
1
4 5 2
1 1
2 3
3 2
4 2
4 4
1 4
2 3
Sample Output
2
给出n个男生和n个女生,m条没有吵架的男女关系,f个女生之间的朋友关系
有n个男生和n个女生配对,由女生挑选男生,女生只跟自己没有吵架的男生配对,或者和自己朋友的没有吵架的男生配对(朋友的朋友也算朋友),求最多能配对几轮?

这题需要二分答案来跑最大流,将女生和能配对的男生建边,容量为1,将源点与女生建边,容量为二分的值,将汇点与男生建边,容量也为二分的值,剩下只剩女生和朋友的没吵过架的男生,这里采用并查集存女生的朋友关系,当两个女生是朋友关系时,将一个女生与另一个女生的没有吵架的男生建边,容量为1,注意要防止重边,所以要加一个数组判断。

#include<stdio.h>
#include<iostream>
#include<cmath>
#include<queue>
#include<cstring>
using namespace std;
const int INF=0x3f3f3f3f;
const int maxn=1e4+5;
const int maxm=1e5+5;
int n,m,S,T,ne,head[maxn],cur[maxn],depth[maxn],maxflow;
int F,f[maxn],vis[105][105];
queue<int> q;
struct edge
{
	int next,to,cost;
}e[maxm*2];
void init()
{
	memset(head,-1,sizeof(head));
	ne=0;
	maxflow=0;
}
void init2()
{
	for(int i = 0; i <= n; i++) f[i] = i;
	memset(vis,0,sizeof(vis));
}
void add(int u,int v,int w)
{
	e[ne].to=v;
	e[ne].cost=w;
	e[ne].next=head[u];
	head[u]=ne++;
	e[ne].to=u;
	e[ne].cost=0;
	e[ne].next=head[v];
	head[v]=ne++;
}
int bfs(int s,int t)
{
	while(!q.empty()) q.pop();
	memset(depth,-1,sizeof(depth));
	for(int i=0;i<=T;i++) cur[i]=head[i];
	depth[s]=0;
	q.push(s);
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		for(int i=head[u];i!=-1;i=e[i].next)
		{
			if(depth[e[i].to]==-1&&e[i].cost)
			{
				depth[e[i].to]=depth[u]+1;
				q.push(e[i].to);
			}
		}
	}
	if(depth[t]==-1) return -1;
	else return 1;
}
int dfs(int s,int t,int limit)
{
	if(!limit||s==t) return limit;
	int f,flow=0;
	for(int i=cur[s];i!=-1;i=e[i].next)
	{
		cur[s]=i;
		if(depth[e[i].to]==depth[s]+1&&(f=dfs(e[i].to,t,min(limit,e[i].cost))))
		{
			flow+=f;
			limit-=f;
			e[i].cost-=f;
			e[i^1].cost+=f;
			if(!limit) break;
		}
	}
	return flow;
}
void dinic(int s,int t)
{
	while(bfs(s,t)!=-1)
	{
		maxflow+=dfs(s,t,INF);
	}
}
int find(int x)
{
  return f[x] == x ? x : f[x] = find(f[x]);
}
void unit(int x, int y)
{
  int fx = find(x);
  int fy = find(y);
  f[fx] = fy;
}
bool same(int x, int y)
{
  return find(x) == find(y);
}
void build(int x)
{
	init();
	for(int i=1;i<=n;i++)
	{
		add(S,i,x);
		add(i+n,T,x);
	}
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=n;j++)
		{
			if(vis[i][j]) add(i,j+n,1);
			if(same(i,j))
			{
				for(int k=1;k<=n;k++)
				{
					if(vis[i][k]&&!vis[j][k])
					{
						vis[j][k]=1;
						add(j,k+n,1);
					}
				}
			}
		}
	}
	dinic(S,T);
}
int main()
{
	int tt;
	scanf("%d",&tt);
	while(tt--)
	{
		scanf("%d %d %d",&n,&m,&F);
		S=0;
		T=2*n+1;
		init2();
		for(int i=0;i<m;i++)
		{
			int x,y;
			scanf("%d%d",&x,&y);
			vis[x][y]=1;
		}
		for(int i=0;i<F;i++)
		{
			int x,y;
			scanf("%d %d",&x,&y);
			unit(x,y);
		}
		int st=0,ed=n+1;
		while(ed-st>1)
		{
			int mid=(ed+st)/2;
			build(mid);
			if(maxflow==n*mid) st=mid;
			else ed=mid;
		}
		printf("%d\n",st);
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值