hdu 1078 FatMouse and Cheese

11 篇文章 0 订阅

Problem Description

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location 
is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of 
cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or
 vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time 
he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the 
cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location 
which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can
 eat before being unable to move. 

Input

There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the
 next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected. 

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37
 
 
一道记忆化的搜索题目,意思是吃东西,在规定的k之内 x相等,y的差的绝对值相差k, 或者y相等
x的差的绝对值相差k,在步数范围之内,你可以随便怎么走和选择吃哪个。一开始根本不造这是个
,就用普通搜素,并不能达到最大值,然后看了博客发现只要在规定步数的范围内,搜素达到最大值即可, 
题目还有要求就是,当越界的时候取边界值、

其实就是  搜索出一条最长的路。保证值最大。

#include<iostream>
#include<cstring>
#include<stdio.h>
#include<stdlib.h>
using namespace std;
int n,k;
int s[110][110];
int biaoji[110][110];
int sou(int x,int y)
{
	int i,j;
	if(biaoji[x][y]==0)
	{
		int a,b;
		int t;
		int sum=0;
		a=x-k;  if(a<0) a=0;
		b=x+k;  if(b>=n)  b=n-1;
		
		for(i=a;i<=b;i++)
		{
			if(s[i][y]>s[x][y])
			{
				t=sou(i,y);
				if(sum<t)
				sum=t;
			}
		}
		a=y-k; if(a<0) a=0;
		b=y+k;  if(b>=n)  b=n-1;
		for(i=a;i<=b;i++)
		{
			if(s[x][i]>s[x][y])
			{
				t=sou(x,i);
				if(sum<t)
				sum=t;
			}
		}
		biaoji[x][y]=sum+s[x][y];
	}
	return biaoji[x][y];
}
int main()
{
	int i,j;
	while(cin>>n>>k)
	{
		if(n==-1&&k==-1)  break;
		memset(biaoji,0,sizeof(biaoji));
		for(i=0;i<n;i++)
		for(j=0;j<n;j++)
		scanf("%d",&s[i][j]);
		int sum=sou(0,0);
		cout<<sum<<endl;
	}
	return 0;
	
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值