Easier Done Than Said?

Easier Done Than Said?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10391 Accepted Submission(s): 5012


Problem Description
Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.
FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

It must contain at least one vowel.

It cannot contain three consecutive vowels or three consecutive consonants.

It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'.

(For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.

Input
The input consists of one or more potential passwords, one per line, followed by a line containing only the word 'end' that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.

Output
For each password, output whether or not it is acceptable, using the precise format shown in the example.

Sample Input
  
  
a tv ptoui bontres zoggax wiinq eep houctuh end

Sample Output
  
  
<a> is acceptable. <tv> is not acceptable. <ptoui> is not acceptable. <bontres> is not acceptable. <zoggax> is not acceptable. <wiinq> is not acceptable. <eep> is acceptable. <houctuh> is acceptable.

Source
下面是一个队友做的。让我看了一下错误,然后...我看了!end处理有点问题(我偶然间发现的,如果改成char str[3]={'e','n','d'};就不对了...)然后把他代码贴下来了,感觉写的挺好
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <iostream>
#include <ctype.h>
#include <iomanip>
#include <queue>
#include <stdlib.h>
using namespace std;

int main()
{
	char s[1000];
	while(~scanf("%s",s)){
		char st[4]="end";
		if(strcmp(st,s)==0){
			break;
		}
		int n=strlen(s);
		int t1=0,t2=0,t3=0,t4=0,t5=0;
		for(int i=0;i<n;i++){
			if(s[i]!='a'&&s[i]!='e'&&s[i]!='i'&&s[i]!='o'&&s[i]!='u'){
				t1++;
				t2=0;
				if(t1==3){
					t5++;
					printf("<%s> is not acceptable.\n",s);
					break;
				}
			}
			else{
				
				t2++;
				t1=0;
				t4++;
				if(t2==3){
					t5++;
					printf("<%s> is not acceptable.\n",s);
					break;
				}
			}
			if(s[i]==s[i+1]&&n!=1&&i!=(n-1)&&s[i]!='e'&&s[i]!='o')
			{
					t5++;
					printf("<%s> is not acceptable.\n",s);
					break;
			}
		}
		if(t4>0&&t5==0)
		{
			t5++;
			printf("<%s> is acceptable.\n",s);
		}
		if(t5==0)printf("<%s> is not acceptable.\n",s);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值