【字符匹配专题】--1001 kmp

Number Sequence

Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 10   Accepted Submission(s) : 5
Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
  
  
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
  
  
6 -1
 


 

 

这个是一个简单的KMP模板的运用,只不过将字符串变成了数组,因此,稍作调整就可A过去,但第一次提交却TLE了....看了看,就把c++中的cin改成scanf...AC了,╮(╯▽╰)╭,习惯使用C++输入输出的伤不起啊...

 

#include <iostream>
using namespace std;



int a[1000005],b[10005],x,y;
int next[10005];


void get_next( )
{
	int i,j;
	i=1;
	next[1]=0;
	j=0;
	while(i<y)
	{
		if(j==0||b[i-1]==b[j-1])
		{
			i++;
			j++;
			if(b[i-1]!=b[j-1])
			next[i]=j;
			else
			next[i]=next[j];
		}
		else
		j=next[j];
	}
}


int kmp()
{
	get_next();
	int i,j;
	//int lens,lent;
	
	i=1;
	j=1;
	while(i<=x&&j<=y)
	{
		if(j==0||a[i-1]==b[j-1])
		{
			i++;
			j++;
		}
		else
		j=next[j];
	}
	if(j>y)
	return i-y;
	else
	return -1;
}


int main()
{
	int n;
	cin>>n;
	while(n--)
	{
		//cin>>x>>y;
		scanf("%d%d",&x,&y);
		for(int i=0;i<x;i++)
		    //cin>>a[i];
		    scanf("%d",&a[i]);
        for(int i=0;i<y;i++)
            //cin>>b[i];
            scanf("%d",&b[i]);
        
        if(x<y)
        {
        	 cout<<-1<<endl;
        	 return 0;
        }
        
        
        int ans=kmp();
        cout<<ans<<endl;
        
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值