HDU 1619 (UVA 116)(单向TSP(算法入门竞赛经典——例题9-4))(翻译,详解)

Unidirectional TSP

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1094    Accepted Submission(s): 523


Problem Description
Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Traveling Salesperson Problem (TSP) -- finding whether all the cities in a salesperson's route can be visited exactly once with a specified limit on travel time -- is one of the canonical examples of an NP-complete problem; solutions appear to require an inordinate amount of time to generate, but are simple to check. 

This problem deals with finding a minimal path through a grid of points while traveling only from left to right. 

Given an m*n matrix of integers, you are to write a program that computes a path of minimal weight. A path starts anywhere in column 1 (the first column) and consists of a sequence of steps terminating in column n (the last column). A step consists of traveling from column i to column i+1 in an adjacent (horizontal or diagonal) row. The first and last rows (rows 1 and m) of a matrix are considered adjacent, i.e., the matrix ``wraps'' so that it represents a horizontal cylinder. Legal steps are illustrated below. 




The weight of a path is the sum of the integers in each of the n cells of the matrix that are visited. 

For example, two slightly different 5*6 matrices are shown below (the only difference is the numbers in the bottom row). 




The minimal path is illustrated for each matrix. Note that the path for the matrix on the right takes advantage of the adjacency property of the first and last rows. 

给一个m行n列(m<=10,n<=100)的整数矩阵,从第一列任何一个位置出发每次往右、右上或右下走一格,最终到达最后一列。要求经过的整数之和最小。整个矩阵是环形的,即第一行的上一行是最后一行,最后一行的下一行是第一行。输出路径上每列的序号。多解时输出字典序最小的。输出最小的整数之和。图中是两个矩阵的最优路线。
 

Input
The input consists of a sequence of matrix specifications. Each matrix specification consists of the row and column dimensions in that order on a line followed by integers where m is the row dimension and n is the column dimension. The integers appear in the input in row major order, i.e., the first n integers constitute the first row of the matrix, the second n integers constitute the second row and so on. The integers on a line will be separated from other integers by one or more spaces. Note: integers are not restricted to being positive. There will be one or more matrix specifications in an input file. Input is terminated by end-of-file. 

For each specification the number of rows will be between 1 and 10 inclusive; the number of columns will be between 1 and 100 inclusive. No path's weight will exceed integer values representable using 30 bits
 

Output
Two lines should be output for each matrix specification in the input file, the first line represents a minimal-weight path, and the second line is the cost of a minimal path. The path consists of a sequence of n integers (separated by one or more spaces) representing the rows that constitute the minimal path. If there is more than one path of minimal weight the path that is lexicographically smallest should be output. 

 

Sample Input
 
 
5 6 3 4 1 2 8 6 6 1 8 2 7 4 5 9 3 9 9 5 8 4 1 3 2 6 3 7 2 8 6 4 5 6 3 4 1 2 8 6 6 1 8 2 7 4 5 9 3 9 9 5 8 4 1 3 2 6 3 7 2 1 2 3 2 2 9 10 9 10
 

Sample Output
 
 
1 2 3 4 4 5 16 1 2 1 5 4 5 11 1 1 19
 

Source
UVA
 

思路:

在这个题目中,每一列就是一个阶段,每个阶段都有三种决策:直行、右上和右下。

设计出状态:dp[i][j]为从格子(i,j)出发到最后一列的最小开销,但是本题不仅要输出解,还要求字典序最小,这就需要在计算dp[i][j]的同时记录“下一列的行号”的最小值(当然是在满足最优性的前提下),细节参见代码:

AC代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
#define INF 0x3f3f3f3f 
using namespace std;
int map[15][105];//存放初始数据 
int dp[15][105];//dp[i][j]为从格子(i,j)出发到最后一列的最小开销 
int pos[15][105];//在格子(i,j)去下一列时,最终选择走向的哪一行(记录路径) 
int m,n;//m行n列 
int main()
{
	while(~scanf("%d %d",&m,&n))
	{
		for(int i=0;i<m;i++)
		for(int j=0;j<n;j++)
		scanf("%d",&map[i][j]);
		for(int j=n-1;j>=0;j--)//n列 ,逆推,从第n-1列推到第0列,第n-1列有初始值 
		{
			for(int i=0;i<m;i++)//m行 
			{
				if(j==n-1) dp[i][j]=map[i][j];//边界情况,最后一列 
				else
				{
					int row[3]={i,i-1,i+1};//存放即将走的,可能的行号(下标从0开始),所在行,下一行,上一行 
					if(i==0) row[1]=m-1;//第0行"上面"是第m-1行 
					if(i==m-1) row[2]=0;//第m-1行"下面"是第0行 
					sort(row,row+3);//重新排列可能去的行号,以便找到字典序最小的
					dp[i][j]=INF;
					for(int k=0;k<3;k++)
					{
						int min=dp[row[k]][j+1]+map[i][j];
						if(min<dp[i][j]) 
						{
							dp[i][j]=min;
							pos[i][j]=row[k];
						}		
					} 
				} 
			}		
		} 
		int ans=INF,first=0; 
		for(int i=0;i<m;i++)
		if(dp[i][0]<ans) ans=dp[i][0],first=i;//从第0列哪一行出发的dp[i][0]最小 
		printf("%d",first+1);//第 下标+1 行  ,先输出在第一列时走的哪一行 
		for(int i=pos[first][0],j=1;j<n;i=pos[i][j],j++)//从第一个位置开始找下一个要去的行,列递增 
		printf(" %d",i+1);
		printf("\n%d\n",ans);
	}
	return 0;
} 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值