(STL—map用法)HDU 1029 Ignatius and the Princess IV


map默认按键值由小到大排序,并且过滤掉重复输入的键值,与set容器相似,不同的是map多了一个映照

键值和映照数据可以自定义类型

如上例子的具体实现:
#include <map> 
#include <string> 
#include <iostream> 
using namespace std; 
int main(int argc, char* argv[]) 
{ 
 //定义map对象,当前没有任何元素
 map<string,float> m; 
 //插入元素,按键值的由小到大放入黑白树中
 m["Jack"]=98.5; 
 m["Bomi"]=96.0; 
 m["Kate"]=97.5; 
 //向前遍历元素
 map<string,float>::iterator it; 
 for(it=m.begin();it!=m.end();it++) 
 { 
 //输出键值与映照数据
 cout<<(*it).first<<" : "<<(*it).second<<endl; 
 } 
 return 0; 
} 
运行结果:
Bomi : 96 
Jack : 98.5 
Kate : 97.5 

例题:

Ignatius and the Princess IV

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 40654    Accepted Submission(s): 17742


Problem Description
"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 

Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 

Output
For each test case, you have to output only one line which contains the special number you have found.
 

Sample Input
 
 
5 1 3 2 3 3 11 1 1 1 1 1 5 5 5 5 5 5 7 1 1 1 1 1 1 1
 

Sample Output
 
 
3 5 1

AC代码:

#include <map>
#include <stdio.h>
using namespace std;
int main()
{
	int n,x,ans;
	while(~scanf("%d",&n))
	{
		map<int,int> m;
		for(int i=0;i<n;i++)
		{
			scanf("%d",&x);
			m[x]++;	
			if(m[x]>=(n+1)/2) 
			ans=x;
		}
	    printf("%d\n",ans);//找到一个就可以输出了,题中说了只有这么一个特殊数
		/*map<int,int>::iterator it;
		for(it=m.begin();it!=m.end();it++)
		if((*it).second>=(n+1)/2)
		printf("%d\n",(*it).first);*/
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值