HDOJ 1238 Substrings

Substrings

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8078    Accepted Submission(s): 3688


Problem Description
You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.
 

Input
The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string.
 

Output
There should be one line per test case containing the length of the largest string found.
 

Sample Input
  
  
2 3 ABCD BCDFF BRCD 2 rose orchid
 

Sample Output
  
  
2 2
 

题目要求的是求每组字符串中最长子串的长度。简单的搜索入门题,也是很好的字符串题,包含了求反串,求子串,字符串查找,求字符串长度。
 
解题思路:先将字符串按长度从短到长排序,枚举最短的字符串的子串,判断是否都是别的字符串的子串,求出最大长度即可。
代码如下:
 
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

char str[110][100],s1[110],s2[110];//以字符串数组的方式输入每组测试数据 

int main()
{
	int len,min,max,t,n,i,j,k,sign,f;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		min=1000;
		for(i=0;i<n;i++)
		{
			scanf("%s",str[i]);
			len=strlen(str[i]);
			if(min>len)//找到最小串 
			{
				min=len;
				f=i;
			}
		}
		len=strlen(str[f]);
		sign=1;max=0;
		for(i=0;i<len;i++)//最为标本串子串的头 
		{
			for(j=i;j<len;j++)//子串的尾 
			{
				for(k=i;k<=j;k++)//复制两个串,顺序串为s1,逆序串为s2; 
				{
					s1[k-i]=str[f][k];
					s2[j-k]=str[f][k];
				}
				s1[j-i+1]=s2[j-i+1]='\0';//以上三个for循环实现了寻找和存储子串,要耐心看懂原理 
				int len_s=strlen(s1);
				for(k=0;k<n;k++)//枚举所有串 
				{
					if(!strstr(str[k],s1)&&!strstr(str[k],s2))//注意本题求的是每个字符串都有的公共串 
					{
						sign=0;
						break;
					}
				}
				if(len_s>max&&sign)
				   max=len_s;
				sign=1;
			}
		}
		printf("%d\n",max);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值