HDOJ 1022 Train Problem I

Train Problem I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24961    Accepted Submission(s): 9416


Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
 

Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
 

Output
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
 

Sample Input
  
  
3 123 321 3 123 312
 

Sample Output
  
  
Yes. in in in out out out FINISH No. FINISH
Hint
Hint
For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".
 
 
题目的意思是有n辆火车按照序列1的方式进站,是否能按照序列2的方式出站。进站不一定所有火车一次性进入,可以进入火车先出去,再有另一辆火车进来。如果能按照题中给出的两个序列的方式进出站,则把具体的进出站的顺序输出。
 
还是不太会栈与队列,看学长的解题报告写的,具体代码如下:
 
#include<stdio.h>
#include<string.h>
int sign[100];
char s1[100],s2[100],in[100];
int main()
{
	int n,j,i,k,ans;
	while(scanf("%d",&n)!=EOF)
	{
		scanf("%s",s1);
		scanf("%s",s2);
		memset(sign,0,sizeof(sign));
		i=k=ans=-1;
		j=0;
		in[++i]=s1[++ans];//进栈 
		sign[++k]=1;//用数组的值来标记进栈还是出栈 
		while(i<n&&j<n)//如果只进栈不出栈,靠判断i的值来结束循环。如果进栈的全部出栈了,靠j的值跳出循环。i,j值同时控制循环 
		{
			while(i>=0&&in[i]==s2[j])//执行出栈 
			{
				sign[++k]=0;
				--i;
				++j;
			}
			sign[++k]=1;
			in[++i]=s1[++ans];//进栈 
		}
		if(ans==n&&j==n)//控制输出的内容 
		{
			printf("Yes.\n");
			for(i=0;i<k;i++)
			{
				if(sign[i])
				   printf("in\n");
				else
				   printf("out\n");
			}
			printf("FINISH\n");
		}
		else
		    printf("No.\nFINISH\n");
	}
	return 0;
} 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值