HDOJ 2141 Can you find it?(二分查找,binary_search())

Can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 17015    Accepted Submission(s): 4331


Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
  
  
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
  
  
Case 1: NO YES NO
 

 

题意:给出A  B  C三个数列,再给出一个X,问在数列中是否存在元素满足Ai+Bj+Ck=X。

 

典型的二分查找,先将A  B两个集合相加,在使用binary_search()函数进行二分查找。

 

代码如下:

 

#include<cstdio>
#include<algorithm>
using namespace std;
int a[510],b[510],c[510],sum[270000];//注意sum数组的下标大小,应大于500*500; 
int main()
{
	int L,N,M,S,t=1,i,j,x,pos;
	while(scanf("%d%d%d",&L,&N,&M)!=EOF)
	{
		for(i=0;i<L;i++)
		  scanf("%d",&a[i]);
		for(i=0;i<N;i++)
		  scanf("%d",&b[i]);
	    for(i=0;i<L;i++)
	    {
	    	for(j=0;j<N;j++)
	    	  sum[N*i+j]=a[i]+b[j];
	    }
	    sort(sum,sum+L*N);
	    for(i=0;i<M;i++)
	       scanf("%d",&c[i]);
	    printf("Case %d:\n",t++);
	    scanf("%d",&S);
	    while(S--)
	    {
	    	int sign=0;
	    	scanf("%d",&x);
	    	for(i=0;i<M;i++)
	    	{
	    	   if(binary_search(sum,sum+L*M,x-c[i]))
	    	     sign=1;
	    	}
	    	if(sign)
	    	  printf("YES\n");
	    	else
	    	  printf("NO\n");
	    }
	}
	return 0;
} 


 

 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值