HDOJ 5522 Numbers(水,暴力)



Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/262144 K (Java/Others)
Total Submission(s): 32    Accepted Submission(s): 28


Problem Description
There are n numbers A1,A2....An ,your task is to check whether there exists there different positive integers i, j, k ( 1i,j,kn ) such that AiAj=Ak
 

Input
There are multiple test cases, no more than 1000 cases.
First line of each case contains a single integer n. (3n100) .
Next line contains n integers A1,A2....An . (0Ai1000)
 

Output
For each case output "YES" in a single line if you find such i, j, k, otherwise output "NO".
 

Sample Input
   
   
3 3 1 2 3 1 0 2 4 1 1 0 2
 

Sample Output
   
   
YES NO YES
 

题意:给出一串数字,问是否存在不同位置上的数字a,b,c满足于a-b=c。

Bestcoder数据真心弱啊,枚举就过了。

代码如下:

#include<cstdio>
int main()
{
	int n,a[1010],i,j,k;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<n;++i)
			scanf("%d",&a[i]);
			int sign=0;
		for(i=0;i<n;++i)
		{
			for(j=0;j<n;j++)
			{
				for(k=0;k<n;++k)
				{
					if(i!=j&&i!=k&&j!=k)
					{
						if(a[k]==(a[i]-a[j]))
						{
							sign=1;
							break; 
						} 
					}
				}
			}
		}
		if(sign)
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
} 




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值