HDOJ 1133 Buy the Ticket(高精度卡特兰数变形)

Buy the Ticket

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5893    Accepted Submission(s): 2441


Problem Description
The "Harry Potter and the Goblet of Fire" will be on show in the next few days. As a crazy fan of Harry Potter, you will go to the cinema and have the first sight, won’t you?

Suppose the cinema only has one ticket-office and the price for per-ticket is 50 dollars. The queue for buying the tickets is consisted of m + n persons (m persons each only has the 50-dollar bill and n persons each only has the 100-dollar bill).

Now the problem for you is to calculate the number of different ways of the queue that the buying process won't be stopped from the first person till the last person.
Note: initially the ticket-office has no money.

The buying process will be stopped on the occasion that the ticket-office has no 50-dollar bill but the first person of the queue only has the 100-dollar bill.
 

Input
The input file contains several test cases. Each test case is made up of two integer numbers: m and n. It is terminated by m = n = 0. Otherwise, m, n <=100.
 

Output
For each test case, first print the test number (counting from 1) in one line, then output the number of different ways in another line.
 

Sample Input
  
  
3 0 3 1 3 3 0 0
 

Sample Output
  
  
Test #1: 6 Test #2: 18 Test #3: 180
 


题意:电影院只有一个窗口售票,每张票价50元,一共n+m个顾客,有m个人有50元的纸币,其他n个人只有100元的纸币。电影院售票窗口没有预备零钱,问这n+m个人能顺利全都买到票的队列有多少种?


题解:卡特兰数的变形,在卡特兰数中上述的n和m是相等的。一个100元的人进队列就表示一个50元的人出队列,直接求n个数按顺序进队列,出队列的可能种数。 不过这里n和m不相等,需要转化。 详解:点击打开链接   也可以用DP思想求解。


代码如下:


//公式:(n+m)!*C(m-n+1)/(m+1)
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[205][100];//每个下标表示4位数 
int fact[100];

void bignum()//阶乘打表 
{
	int i,j,c,s;
	a[0][99]=a[1][99]=1;
	for(i=2;i<205;++i)
	{
		c=0;
		for(j=99;j>=0;--j)
		{
			s=a[i-1][j]*i+c;
			a[i][j]=s%10000;
			c=s/10000;
		}
	}
}

void MUL(int fact[],int num)//乘法运算 
{
	int i,c=0,s;
	for(i=99;i>=0;--i)
	{
		s=fact[i]*num+c;
		fact[i]=s%10000;
		c=s/10000;
	}
}

void DIV(int fact[],int num)//除法运算 
{
	int c=0,i;
	for(i=0;i<100;++i)
	{
		c=c*10000+fact[i];
		fact[i]=c/num;
		c%=num;
	}
}

int main()
{
	bignum();
	int n,m,t=1;
	while(scanf("%d%d",&m,&n)&&(n||m))
	{
		printf("Test #%d:\n",t++);
		if(n>m)
			printf("0\n");
		else
		{
			memcpy(fact,a[n+m],sizeof(a[n+m]));
			MUL(fact,m-n+1);
			DIV(fact,m+1);
			int i;
			for(i=0;i<100;++i)
				if(fact[i]!=0)
					break;
			printf("%d",fact[i]);
			for(++i;i<100;++i)
				printf("%04d",fact[i]);
			printf("\n");
		}
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值