HDOJ 5813 Elegant Construction(构图)

Elegant Construction

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 695    Accepted Submission(s): 369
Special Judge

Problem Description
Being an ACMer requires knowledge in many fields, because problems in this contest may use physics, biology, and even musicology as background. And now in this problem, you are being a city architect!
A city with N towns (numbered 1 through N) is under construction. You, the architect, are being responsible for designing how these towns are connected by one-way roads. Each road connects two towns, and passengers can travel through in one direction.

For business purpose, the connectivity between towns has some requirements. You are given N non-negative integers a1 .. aN. For 1 <= i <= N, passenger start from town i, should be able to reach exactly ai towns (directly or indirectly, not include i itself). To prevent confusion on the trip, every road should be different, and cycles (one can travel through several roads and back to the starting point) should not exist.

Your task is constructing such a city. Now it's your showtime!
 

Input
The first line is an integer T (T <= 10), indicating the number of test case. Each test case begins with an integer N (1 <= N <= 1000), indicating the number of towns. Then N numbers in a line, the ith number ai (0 <= ai < N) has been described above.
 

Output
For each test case, output "Case #X: Y" in a line (without quotes), where X is the case number starting from 1, and Y is "Yes" if you can construct successfully or "No" if it's impossible to reach the requirements.

If Y is "Yes", output an integer M in a line, indicating the number of roads. Then M lines follow, each line contains two integers u and v (1 <= u, v <= N), separated with one single space, indicating a road direct from town u to town v. If there are multiple possible solutions, print any of them.
 

Sample Input
  
  
3 3 2 1 0 2 1 1 4 3 1 1 0
 

Sample Output
  
  
Case #1: Yes 2 1 2 2 3 Case #2: No Case #3: Yes 4 1 2 1 3 2 4 3 4
 


唉,这多校打不动了,补补上一场的题目。水题,又没想出来 ~~~~(>_<)~~~~


题意:给出n个城市和每个城市能到达其他城市的个数,问如何建一个无欢单向边图满足题目要求?


题解:样例有点误导,没有要求建边数量一定要最少,我们只要满足题意建边数量不做要求。那么我们给左右所有城市按照能达到的城市个数从小到大的顺序排序,对于每个有出度的城市i我们只要往小于i的城市上连接city[i].num条边就可以了,如果能连的边数小于出度,那么就不存在合理方案。


代码如下:


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 1010
struct node
{
	int num,id;
}pint[maxn]; 

int cmp(node x,node y)
{
	return x.num<y.num;
}

int main()
{
	int t,n,u,v,i,j,k=1;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=0;i<n;++i)
		{
			scanf("%d",&pint[i].num);
			pint[i].id=i+1;
		}
		sort(pint,pint+n,cmp);
		int flag=1;
		for(i=0;i<n;++i)
		{
			if(pint[i].num>i)
			{
				flag=0;
				break;
			}
		}
		if(!flag)
			printf("Case #%d: No\n",k++);
		else
		{
			printf("Case #%d: Yes\n",k++);
			int ans=0;
			for(i=0;i<n;++i)
				ans+=pint[i].num;
			printf("%d\n",ans);
			for(i=0;i<n;++i)
			{
				for(j=0;j<pint[i].num;++j)
					printf("%d %d\n",pint[i].id,pint[j].id);
			}
		}
	}
	return 0;
} 





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值